A One Way In, Two Ways Out

该程序设计问题涉及一种特殊的队列结构,允许在一端插入元素,但在两端删除元素。给定一个插入序列和多个查询,任务是判断能否通过删除操作得到查询中的序列。程序接收输入,包括插入序列和删除序列,然后判断每个删除序列是否可行,输出‘yes’或‘no’表示结果。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

测试用例通过,但没有购买题库,不能测试全部用例

Consider a special queue which is a linear structure that allows insertions at one end, yet deletions at both ends. Your job is to check, for a given insertion sequence, if a deletion sequence is possible. For example, if we insert 1, 2, 3, 4, and 5 in order, then it is possible to obtain 1, 3, 2, 5, and 4 as an output, but impossible to obtain 5, 1, 3, 2, and 4.

Input Specification:

Each input file contains one test case. For each case, the first line gives 2 positive integers N and K (≤10), which are the number of insertions and the number of queries, respectively. Then N distinct numbers are given in the next line, as the insertion sequence. Finally K lines follow, each contains N inserted numbers as the deletion sequence to be checked.

All the numbers in a line are separated by spaces.

Output Specification:

For each deletion sequence, print in a line yes if it is indeed possible to be obtained, or no otherwise.

Sample Input:

5 4
10 2 3 4 5
10 3 2 5 4
5 10 3 2 4
2 3 10 4 5
3 5 10 4 2

Sample Output:

yes
no
yes
yes
#include<iostream>
using namespace std;
int main(){
	int n,k;
	cin>>n>>k;
	int flag = 1;
	int input[n];
	int visit[n];
	int output[n];
	for(int i=0;i<n;i++){
		cin>>input[i];
		visit[i]=1;
	}
	for(int i=0;i<k;i++){
		int front = 0,rear = -1;
		for(int i=0;i<n;i++){
			cin>>output[i];
			visit[i]=1;
		}
		for(int j = 0;j<n;j++){
			int index = 0;
			while(input[index]!=output[j]){
				index++;
			}
			if(index==front){
				visit[front]=0;
				front++;
			}else{
				if(rear < front){
					visit[index]=0;
					rear = index-1;
				}else{
					if(index>front&&index<rear){
						flag = false;
						break;
					}else{
						visit[index] = 0;
						rear = index-1;
						while(visit[rear]==0&&rear>=0){
							rear--;
						}
					}
				}
			}
		}
		if(flag){
			cout<<"yes";
		}else{
			cout<<"no";
			flag = true;
		}
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值