2018 Multi-University Training Contest 5.Everything Has Changed

这篇博客介绍了2018年多所大学训练赛第5题,题目涉及机械臂在二维坐标系中切割圆形工件的问题。每个机械臂切割出一个圆形区域,所有切割区域互不相交且不覆盖整个原始圆。任务是计算经过所有切割后,原始圆盘剩余部分的周长。题目提供了输入输出格式、样例以及解题思路,解题关键在于使用余弦定理来确定切割后边缘的角度。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Everything Has Changed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3444    Accepted Submission(s): 909
Special Judge

 

Problem Description

Edward is a worker for Aluminum Cyclic Machinery. His work is operating mechanical arms to cut out designed models. Here is a brief introduction of his work.
Assume the operating plane as a two-dimensional coordinate system. At first, there is a disc with center coordinates (0,0) and radius R. Then, m mechanical arms will cut and erase everything within its area of influence simultaneously, the i-th area of which is a circle with center coordinates (xi,yi) and radius ri (i=1,2,⋯,m). In order to obtain considerable models, it is guaranteed that every two cutting areas have no intersection and no cutting area contains the whole disc.
Your task is to determine the perimeter of the remaining area of the disc excluding internal perimeter.
Here is an illustration of the sample, in which the red curve is counted but the green curve is not.

 

 

Input

The first line contains one integer T, indicating the number of test cases.
The following lines describe all the test cases. For each test case:
The first line contains two integers m and R.
The i-th line of the following m lines contains three integers xi,yi and ri, indicating a cutting area.
1≤T≤1000, 1≤m≤100, −1000≤xi,yi≤1000, 1≤R,ri≤1000 (i=1,2,⋯,m).

 

 

Output

For each test case, print the perimeter of the remaining area in one line. Your answer is considered correct if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a and the jury's answer be b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6.

 

 

Sample Input

 

1 4 10 6 3 5 10 -4 3 -2 -4 4 0 9 1

 

 

Sample Output

 

81.62198908430238475376

解题思路:利用余弦定理及三边长度求出两个角,剩下正常操作即可。

#include<bits/stdc++.h>
using namespace std;
#define pi acos(-1.0)

int main()
{
    int t,m;
    scanf("%d",&t);
    double R;
    while(t--&&scanf("%d%lf",&m,&R))
    {
        double ans=0,x,y,r,a1,a2,a3;
        ans=2*pi*R;
        for(int i=0; i<m; i++)
        {
            scanf("%lf%lf%lf",&x,&y,&r);
            a3=sqrt(x*x+y*y);
            if(R+r<=a3||R-r>a3) continue;
            else if(R-r==a3) ans+=2*pi*r;
            else
            {
                a1=R,a2=r;
                double w=acos((a2*a2+a3*a3-a1*a1)/(2*a2*a3));
                double ww=(w)*2*r;
                ans+=ww;
                double www=acos((a1*a1+a3*a3-a2*a2)/(2*a1*a3));
                ans-=www*2*R;
            }
        }
        printf("%.11f\n",ans);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值