Poj.3264.Balanced Lineup(线段树)

本文介绍了一道关于寻找连续范围内最大值与最小值之差的问题,并详细讲解了使用线段树解决此问题的方法。文章包括完整的代码实现,帮助读者理解如何高效地处理这类查询。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Poj.3264.Balanced Lineup

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output
Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0

题意:给定一序列,求指定区间上最大值与最小值之差

考点:线段树

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

const int N=50007;
struct st                          //Segment Tree:每个点代表一条线段
{
    int left,right;                //非元线段的左右孩子
    int mina;                      //线段上的最大最小值
    int maxa;
};
st q[N*4];                         //开4*N的数组以免越界
int n,m,ans1,ans2;

void build(int num,int L,int R)    //构造线段树:节点个数,左边界,右边界
{
    q[num].left=L;
    q[num].right=R;
    if(L==R)
    {
        scanf("%d",&q[num].maxa);
        q[num].mina=q[num].maxa;
        return;
    }
    build(2*num,L,(L+R)/2);                                      //左孩子区间
    build(2*num+1,(L+R)/2+1,R);                                  //右孩子区间
    q[num].mina=min(q[2*num].mina,q[2*num+1].mina);
    q[num].maxa=max(q[2*num].maxa,q[2*num+1].maxa);
}

int get_max(int num,int s,int t)                                 //区间[s,t]上最大值
{
    if(q[num].left>=s&&q[num].right<=t) 
        return q[num].maxa;
    int mid=(q[num].left+q[num].right)/2;
    if(mid>=t) 
        return get_max(2*num,s,t);
    else if(mid<s) 
        return get_max(2*num+1,s,t);
    else 
        return max(get_max(2*num,s,mid),get_max(2*num+1,mid+1,t));
}

int get_min(int num,int s,int t)                                 //区间[s,t]上最小值
{
    if(q[num].left>=s&&q[num].right<=t)
        return q[num].mina;
    int mid=(q[num].left+q[num].right)/2;
    if(mid>=t)
        return get_min(2*num,s,t);
    else if(mid<s)
        return get_min(2*num+1,s,t);
    else
        return min(get_min(2*num,s,mid),get_min(2*num+1,mid+1,t));
}

int main()
{
    scanf("%d%d",&n,&m);                                          //n个节点,m次询问
    build(1,1,n);                                                 //构造线段树
    while(m--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        printf("%d\n",get_max(1,a,b)-get_min(1,a,b));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值