Can you find it?
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO
题目大意:在A、B、C三个数组中各选出一个数,看能否使得三个数之和为给定的数。只需讲其中两个数组中任意两个元素相加得到一个新的数组,再与剩下的数组中每一个元素进行二分即可
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 510;
int a[maxn], b[maxn], c[maxn], d[maxn*maxn];
int cnt;
int bs(int x)
{
int hi;
int lo;
int mid;
lo = 0;
hi = cnt-1;
while(hi>=lo)
{
mid = (lo+hi) >> 1;
if(d[mid]<x)
lo = mid + 1;
else if(d[mid]>x)
hi = mid - 1;
else
return 1;
}
return 0;
}
int main()
{
int l, m, n, k, s;
int flag = 1;
while(cin >> l >> m >> n)
{
for(int i = 0; i < l; i++)
{
cin >> a[i];
}
for(int i = 0; i < m; i++)
{
cin >> b[i];
}
for(int i = 0; i < n; i++)
{
cin >> c[i];
}
cnt = 0;
for(int i = 0; i < m; i++)
{
for(int j = 0; j < n; j++)
{
d[cnt++] = b[i] + c[j];
}
}
sort(d, d+cnt);
sort(a, a+l);
cin >> s;
printf("Case %d:\n", flag++);
int sum;
while(s--)
{
cin >> sum;
int ok = 0;
/*if(a[0]+d[0]>sum || a[l-1]+d[cnt-1]<sum)
{
cout << "NO" << endl;
continue;
}*/
//这段优化代码加进去就错了。。我也不知道为什么,有人如果能看出来原因请告诉我
for(int j = 0; j < l; j++)
{
if(bs(sum-a[j]))
{
ok = 1;
break;
}
}
if(ok)
cout << "YES" << endl;
else
cout << "NO" << endl;
}
}
return 0;
}