poj 3678 Katu Puzzle

Katu Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6820 Accepted: 2505

Description

Katu Puzzle is presented as a directed graph G(V, E) with each edge e(a, b) labeled by a boolean operator op (one of AND, OR, XOR) and an integer c (0 ≤ c ≤ 1). One Katu is solvable if one can find each vertex Vi a value Xi (0 ≤ Xi ≤ 1) such that for each edge e(a, b) labeled by op and c, the following formula holds:

 Xa op Xb = c

The calculating rules are:

AND01
000
101
OR01
001
111
XOR01
001
110

Given a Katu Puzzle, your task is to determine whether it is solvable.

Input

The first line contains two integers N (1 ≤ N ≤ 1000) and M,(0 ≤ M ≤ 1,000,000) indicating the number of vertices and edges.
The following M lines contain three integers a (0 ≤ a < N), b(0 ≤ b < N), c and an operator op each, describing the edges.

Output

Output a line containing "YES" or "NO".

Sample Input

4 4
0 1 1 AND
1 2 1 OR
3 2 0 AND
3 0 0 XOR

Sample Output

YES

Hint

X 0 = 1, X 1 = 1, X 2 = 0, X 3 = 1.
 
题意:一个有向图,给出m个关系a b c op,op是操作种类,有and、or、xor三种,问是否能找出全部结点的值(0或1),使得满足所有的m个关系:a op b=c。
思路:还是2-SAT问题。重要的是如何构图,谨记要连边a->b时,当且仅当选了a就必须选b。所以要这样构图(a表示取0,a+n表示取1):
op=AND:
c=1: a+n->b+n
         b+n->a+n
         a->a+n      因为这时a和b必须同时为1,a->a+n可以保证a必须为1,下同
         b->b+n
c=0:  a+n->b
          b+n->a
 
op=OR:
c=1: a->b+n
         b->a+n
c=0: a->b
         b->a
         a+n->a
         b+n->b
 
op=XOR:
c=1: a->b+n
         a+n->b
         b->a+n
         b+n->a
c=0: a->b
         a+n->b+n
         b->a
         b+n->a+n
 
 
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <map>
#include <cstdlib>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define ll long long
using namespace std;

const int maxn=2005;
const int INF=1000000000;
struct node
{
    int v,next;
}edge[maxn*maxn];
int head[maxn],scc[maxn],stack[maxn];
int low[maxn],dfn[maxn];
bool ins[maxn];
int n,m,num,cnt,top,snum;
void init()
{
    memset(head,-1,sizeof(head));
    num=0;
}
void add(int u,int v)
{
    edge[num].v=v;
    edge[num].next=head[u];
    head[u]=num++;
}
void input()
{
   int a,b,c;
   char op[5];
   while(m--)
   {
       scanf("%d%d%d%s",&a,&b,&c,op);
       if(op[0]=='A')
       {
           if(c==1)
           {
               add(a+n,b+n);
               add(b+n,a+n);
               add(a,a+n);
               add(b,b+n);
           }
           else
           {
               add(a+n,b);
               add(b+n,a);
           }
       }
       else if(op[0]=='O')
       {
           if(c==1)
           {
               add(a,b+n);
               add(b,a+n);
           }
           else
           {
               add(a,b);
               add(b,a);
               add(a+n,a);
               add(b+n,b);
           }
       }
       else
       {
           if(c==1)
           {
               add(a,b+n);
               add(a+n,b);
               add(b,a+n);
               add(b+n,a);
           }
           else
           {
               add(a,b);
               add(a+n,b+n);
               add(b,a);
               add(b+n,a+n);
           }
       }
   }
}
void dfs(int u)
{
    int x;
    dfn[u]=low[u]=++cnt;
    stack[top++]=u;
    ins[u]=true;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(!dfn[v])
        {
            dfs(v);
            low[u]=min(low[u],low[v]);
        }
        else if(ins[v]) low[u]=min(low[u],dfn[v]);
    }
    if(low[u]==dfn[u])
    {
        do{
            x=stack[--top];
            ins[x]=false;
            scc[x]=snum;
        }while(x!=u);
        snum++;
    }
}
void tarjan()
{
    memset(dfn,0,sizeof(dfn));
    memset(ins,false,sizeof(ins));
    cnt=top=snum=0;
    for(int i=0;i<2*n;i++)
    if(!dfn[i]) dfs(i);
}
void solve()
{
    for(int i=0;i<n;i++)
    if(scc[i]==scc[i+n])
    {
        printf("NO\n");
        return;
    }
    printf("YES\n");
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();
        input();
        tarjan();
        solve();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值