HDU:2028 lowest common multiple plus

必须滚瓜烂熟求最大公倍数和最小公约数

Problem Description

求n个数的最小公倍数。


Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。


Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。


Sample Input
2 4 6
3 2 5 7


Sample Output
12

70

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
int lcd(int a,int b)
{
    int k=a;
    while(k%b!=0){
        k+=a;
    }
    return k;
}
int main()
{
    int n,i,j;
    int a[120];
    while(scanf("%d",&n)!=EOF){
        for(i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        j=lcd(a[0],a[1]);
        for(i=2;i<n;i++){
            j=lcd(j,a[i]);
        }
        printf("%d\n",j);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值