HDU - 1385 A - Minimum Transport Cost

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

题意:有n个城市,给出这n个城市的矩阵表,-1代表不通路,剩下的代表过路费,经过每个城市也要给过路费,问从一个起点到一个终点的最小花费,如果有多种路径符合,则输出字典序最小的那个。

分析:这道题求最短路,用Floyd来求出俩个城市之间的最短花费,还要再建一个数组记录所经过的路径。

代码 :

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int n;
int d[110];
int map[110][110];
int path[110][110];
void floyd()
{
    int v;
    for(int i=1; i<=n; i++)       //初始化路径
        for(int j=1; j<=n; j++)
            path[i][j]=j;
    for(int k=1; k<=n; k++)
    {
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                v=map[i][k]+map[k][j]+d[k]; 
                if(v<map[i][j])
                {
                    map[i][j]=v;
                    path[i][j]=path[i][k];
                }
                else if(v==map[i][j])
                {
                    if(path[i][j]>path[i][k])     //找字典序最小的
                        path[i][j]=path[i][k];
                }
            }
        }
    }
}
int main()
{
    int st,en,k;
    while(~scanf("%d",&n),n)
    {
        for(int i=1; i<=n; i++)       //矩阵表
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&k);
                if(k==-1)map[i][j]=INF;
                else map[i][j]=k;
            }
        for(int i=1;i<=n;i++)     //各城市的收费
            scanf("%d",&d[i]); 
        floyd();                 //Floyd
        while(scanf("%d%d",&st,&en))
        {
            if(st==-1&&en==-1)
                break;
            printf("From %d to %d :\n",st,en);
            printf("Path: %d",st);
            k=st;
            while(k!=en)        //输出路径
            {
                printf("-->%d",path[k][en]);
                k=path[k][en];           
            }
            printf("\n");
            printf("Total cost : %d\n\n",map[st][en]);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值