HDU 3001Travelling (状压DP)

文章讨论了一个关于旅行者如何在有限的城市中最小化费用的问题,包括输入格式、输出要求及解决策略,涉及到路径选择和费用优化。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >



Travelling

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3686    Accepted Submission(s): 1151


Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input
  
  
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output
  
  
100 90 7
  
  思路:TSP类问题,注意每个点最多走两次,所以要用三进制表示。可以预处理出状态的每一位是什么
#include <iomanip>
#include <cstdio>
#include <map>
#include <queue>
#include <cstring>
#include <iostream>
#include <vector>
#include <cmath>
#include <string>
using namespace std;
#define LL long long 
const int mod =1e8;
#define inf 0x1f1f1f1f
#define lson id<<1,l,mid  
#define rson id<<1|1,mid+1,r

int fin[12]={0,1,3,9,27,81,243,729,2187,6561,19683,59049};
int getdigit[59049+10][11],dp[59049+10][11],dis[11][11],n,m,vis[11][11];

int main()
{
	for(int s=0;s<59050;s++)
	{
		int temp=s;
		for(int i=1;i<=10;i++)
		{
			getdigit[s][i]=temp%3;
			temp/=3;
			if(temp==0) break;
		}
	}
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int a,b,c;
		memset(vis,0,sizeof(vis));
		memset(dp,inf,sizeof(dp));
		memset(dis,inf,sizeof(dis));
		
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(vis[a][b])
			{
				dis[a][b]=min(dis[a][b],c);
				dis[b][a]=dis[a][b];
			}
			else 
			{
				dis[a][b]=dis[b][a]=c;
				vis[a][b]=vis[b][a]=1;
			}
		}

		bool flag;
		int ans=inf;
		for(int i=1;i<=n;i++) dp[fin[i]][i]=0;
		for(int s=0;s<fin[n+1];s++)
		{
			flag=1;
			for(int i=1;i<=n;i++)
			{
				if(getdigit[s][i]==0) flag=0;
				if(dp[s][i]==inf) continue;
				for(int j=1;j<=n;j++)
				{
					if(j==i) continue;
					if(dis[i][j]==inf||getdigit[s][j]>=2) continue;
					dp[s+(fin[j])][j]=min(dp[s+(fin[j])][j],dp[s][i]+dis[i][j]);
				}
			}
			if(flag)
			{
				for(int i=1;i<=n;i++)
				{
					ans=min(ans,dp[s][i]);
				}
			}
		}
		if(ans==inf) puts("-1");
		else printf("%d\n",ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值