Xiao Ming's Hope
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1316 Accepted Submission(s): 888
Problem Description
Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C
(n,0)+C
(n,1)+C
(n,2)+...+C
(n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C
(1,0)=C
(1,1)=1, there are 2 odd numbers. When n is equal to 2, C
(2,0)=C
(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?
Input
Each line contains a integer n(1<=n<=10
8)
Output
A single line with the number of odd numbers of C
(n,0),C
(n,1),C
(n,2)...C
(n,n).
Sample Input
1 2 11
Sample Output
2 2 8
Author
HIT
思路:组合数奇偶性的判断:若n&m==m则是奇数,
否则为偶数.
#include <algorithm>
#include <cstdio>
#include <map>
#include <queue>
#include <cstring>
#include <iostream>
#include <vector>
#include <cmath>
#include <string>
using namespace std;
#define LL long long
#define mod 1000000007
#define inf 1<<28
#define lson id<<1,l,mid
#define rson id<<1|1,mid+1,r
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int ans=0;
while(n)
{
if(n%2) ans++;
n/=2;
}
cout<<(1<<ans)<<endl;
}
return 0;
}
否则为偶数.
有了这个结论本题就好做了,将n写成二进制数,其中为0的地方m必为0,为1的地方可以为0或者1,统计n 中1的个数c,答案即为2^c.