1.R5为ISP,只能进行IP地址配置;其所有地址均为公有IP地址
[ISP-Serial3/0/0]ip address 15.0.0.2 8
[ISP-Serial3/0/1]ip add 25.0.0.2 8
[ISP-Serial4/0/0]ip add 35.0.0.2 8
[ISP-GigabitEthernet0/0/0]ip add 45.0.0.2 8
2.R1和R5间使用PPP的PAP认证,R5为主认证方;
[r1]ip route-static 0.0.0.0 0 15.0.0.2
[r2]ip route-static 0.0.0.0 0 25.0.0.2
[r3]ip route-static 0.0.0.0 0 35.0.0.2
[r4]ip route-static 0.0.0.0 0 45.0.0.2
[ISP-aaa]local-user huawei password cipher 123456
Info: Add a new user.
[ISP-aaa]local-user huawei service-type ppp
[ISP-Serial3/0/0]ppp authentication-mode pap
[r1-Seria4/0/0]ppp pap local-user huawei password cipher 123456
R2与R5之间使用PPP的chap认证,R5为主认证方;
[ISP-Serial3/0/1]ppp authentication-mode chap
[r2-Seria4/0/0]ppp chap user huawei
[r2-Seria4/0/0]ppp chap password cipher 123456
R3与R5之间使用HDLC封装。
[ISP-Serial4/0/0]display this
[V200R003C00]
#
interface Serial4/0/0
link-protocol hdlc
ip address 35.0.0.2 255.0.0.0
#
Return
[r3-Serial4/0/0]display this
[V200R003C00]
#
interface Serial4/0/0
link-protocol hdlc
ip address 35.0.0.1 255.255.255.0
#
return
3.R1/R2/R3构建一个MGRE环境,R1为中心站点;R1、R4间为点到点的GRE。
[r1-Tunnel0/0/0]display this
[V200R003C00]
#
interface Tunnel0/0/0
ip address 192.168.5.1 255.255.255.0
tunnel-protocol gre p2mp
source Serial4/0/0
nhrp network-id 10
#
Return
[r2-Tunnel0/0/0]display this
[V200R003C00]
#
interface Tunnel0/0/0
ip address 192.168.5.2 255.255.255.0
tunnel-protocol gre p2mp
source Serial4/0/0
nhrp network-id 10
nhrp entry 192.168.5.1 15.0.0.1 register
#
return
[r3-Tunnel0/0/0]display this
[V200R003C00]
#
interface Tunnel0/0/0
ip address 192.168.5.3 255.255.255.0
tunnel-protocol gre p2mp
source Serial4/0/0
nhrp network-id 10
nhrp entry 192.168.5.1 15.0.0.1 register
#
Return
[r1-Tunnel0/0/1]display this
[V200R003C00]
#
interface Tunnel0/0/1
ip address 192.168.6.1 255.255.255.0
tunnel-protocol gre
source Serial4/0/0
destination 45.0.0.1
#
Return
[R4-Tunnel0/0/0]display this
[V200R003C00]
#
interface Tunnel0/0/0
ip address 192.168.6.2 255.255.255.0
tunnel-protocol gre
source GigabitEthernet0/0/1
destination 15.0.0.1
#
return
4.整个私有网络基于RIP全网可达
[r1-rip-1]display this
[V200R003C00]
#
rip 1
version 2
network 192.168.1.0
network 192.168.5.0
network 192.168.6.0
#
Return
[r1-Tunnel0/0/0]display this
[V200R003C00]
#
interface Tunnel0/0/0
ip address 192.168.5.1 255.255.255.0
undo rip split-horizon
tunnel-protocol gre p2mp
source Serial4/0/0
nhrp entry multicast dynamic
nhrp network-id 10
#
Return
[r2-rip-1]display this
[V200R003C00]
#
rip 1
version 2
network 192.168.2.0
network 192.168.5.0
#
Return
[r3-rip-1]display this
[V200R003C00]
#
rip 1
version 2
network 192.168.3.0
network 192.168.5.0
#
Return
[R4-rip-1]display this
[V200R003C00]
#
rip 1
version 2
network 192.168.4.0
network 192.168.6.0
#
Return
5.所有PC设置私有IP为源IP,可以访问R5环回
[ISP-LoopBack0]display this
[V200R003C00]
#
interface LoopBack0
ip address 12.0.0.1 255.255.255.0
#
Return
[r1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[r1-Serial4/0/0]nat outbound 2000
[r2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[r2-Serial4/0/0]nat outbound 2000
[r3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[r3-Serial4/0/0]nat outbound 2000
[R4-acl-basic-2000]rule permit source 192.168.4.0 0.0.0.255
[R4-GigabitEthernet0/0/1]nat outbound 2000