1113 Integer Set Partition (25 分)

该博客讨论了一种算法问题,即如何将一组正整数分成两组,使得两组元素数量之差最小,并且这两组的和之差最大化。输入包含一组不超过10^5个的正整数,要求首先最小化数量差,然后最大化和的差。程序通过排序整数并等分(如果数量为偶数)或接近等分(如果数量为奇数)来实现这一目标。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1113 Integer Set Partition (25 分)

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1 and n2 numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2, respectively. You are supposed to make the partition so that ∣n1n2∣ is minimized first, and then ∣S1S2∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤105), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

Output Specification:

For each case, print in a line two numbers: ∣n1n2∣ and ∣S1S2∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

Analysis

简单题,无坑点无槽点

Code(C++)

#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    int num;
    cin >> num;
    int a[num];
    for(int i=0; i<num; i++)
        cin >> a[i];
    
    sort(a, a+num);
    
    int n1 = num / 2;
    int n2 = num - n1;
    int sum1 = 0, sum2 = 0;
    for(int i=0; i<n1; i++)
        sum1 += a[i];
    for(int i=n1; i<num; i++)
        sum2 += a[i];
    
    cout << n2-n1 << " " << sum2 - sum1 << endl;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值