Ascending RatingTime Limit: 10000/5000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)Total Submission(s): 1536 Accepted Submission(s): 429 Problem Description Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i -th contestant's QodeForces rating is ai .
Input The first line of the input contains an integer T(1≤T≤2000) , denoting the number of test cases. ai=(p×ai−1+q×i+r)modMOD It is guaranteed that ∑n≤7×107 and ∑k≤2×106 .
Output Since the output file may be very large, let's denote maxratingi and counti as the result of interval [i,i+m−1] .For each test case, you need to print a single line containing two integers A and B , where : AB==∑i=1n−m+1(maxratingi⊕i)∑i=1n−m+1(counti⊕i) Note that ``⊕ '' denotes binary XOR operation.
Sample Input 1 10 6 10 5 5 5 5 3 2 2 1 5 7 6 8 2 9
Sample Output 46 11
Source 2018 Multi-University Training Contest 3
Recommend chendu | We have carefully selected several similar problems for you: 6331 6330 6329 6328 6327 |
题意:给定一个序列 a[1..n],对于每个长度为 m 的连续子区间,求出区间 a 的最大值以及从左往右扫描该区间时 a 的最大值的
变化次数。
分析:首先要知道是用单调队列维护a,这就是经典的滑窗最大值问题。但是题目还要求这个一个最大值变化的次数,看了题解,如果倒着维护,那么单调队列中单元素的个数就是最大值的变化次数,用手模拟的一下。
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<vector>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<deque>
#include<ctype.h>
#include<map>
#include<set>
#include<stack>
#include<string>
#define INF 0x3f3f3f3f
#define FAST_IO ios::sync_with_stdio(false)
const double PI = acos(-1.0);
const double eps = 1e-6;
const int MAX=1e5+10;
typedef long long ll;
using namespace std;
#define gcd(a,b) __gcd(a,b)
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
inline ll exgcd(ll a,ll b,ll &x,ll &y){if(!b){x=1;y=0;return a;}ll r=exgcd(b,a%b,y,x);y-=(a/b)*x;return r;}
inline ll read(){ll x=0,f=1;char c=getchar();for(;!isdigit(c);c=getchar()) if(c=='-') f=-1;for(;isdigit(c);c=getchar()) x=x*10+c-'0';return x*f;}
//freopen( "in.txt" , "r" , stdin );
//freopen( "data.txt" , "w" , stdout );
ll a[70000005];
ll p,q,r,mod,k;
ll n,m,ans1,ans2;
ll s[70000005];
ll t,h;
int main()
{
ll T;
scanf("%lld",&T);
while(T--)
{
scanf("%lld%lld%lld%lld%lld%lld%lld",&n,&m,&k,&p,&q,&r,&mod);
for(ll i=1;i<=k;i++) scanf("%lld",&a[i]);
for(ll i=k+1;i<=n;i++)
a[i]=(1ll*p*a[i-1]+1ll*q*i+r)%mod;
t=0;
h=1;
for(int i=n;i;i--)
{
while(t>=h && a[s[t]]<=a[i])
t--;
s[++t]=i;
if(i+m-1<=n)
{
while(s[h]>=i+m)
h++;
ans1+=a[s[h]]^i;
ans2+=(t-h+1)^i;
}
}
printf("%lld %lld\n",ans1,ans2);
}
return 0;
}