POJ 2395--Out of Hay

本文探讨了一种算法问题,即求解最小生成树中最大的边长。通过使用优先队列和并查集的数据结构,该问题可以高效地解决。文章提供了一个完整的C++实现示例,并解释了如何最小化在农场间旅行所需的水容量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目:

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M.

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

题意:求最小生成树中的最大值。


实现:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#include <vector>
#include <algorithm>
#include <iostream>
using namespace std;

const int MAX = 20005;
int n, m;

int p[MAX];

int _find(int x) {
    return p[x] = (p[x] == x ? x : _find(p[x]));
}

struct node {
    int u, v, e;
    bool friend operator < (node n1, node n2) {
        return n1.e > n2.e;
    }
};

int main() {
    while(scanf("%d%d", &n, &m) != EOF) {
        for (int i = 1; i <= n; i++) {
            p[i] = i;
        }
        priority_queue <node> q;
        int u, v, value;
        for (int i = 0; i < m; i++) {
            scanf("%d%d%d", &u, &v, &value);
            node head;
            head.u = u;
            head.v = v;
            head.e = value;
            q.push(head);
        }

        int ans = -1;

        while (!q.empty()) {
            node tt = q.top();
            q.pop();
            int x, y;
            x = _find(tt.u);
            y = _find(tt.v);
            if (x != y) {
                p[y] = x;
                if (ans < tt.e)
                    ans = tt.e;
            }
        }
        printf("%d\n", ans);
     }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值