POJ-2758 checking the text(哈希+二分)

POJ-2758 checking the text(哈希+二分)

题目:
Wind’s birthday is approaching. In order to buy a really really fantastic gift for her, Jiajia has to take a boring yet money-making job - a text checker.

This job is very humdrum. Jiajia will be given a string of text what is English letters and he must count the maximum number of letters that can be matched, starting from two position of the current text simultanously. The matching proceeds from left to right, one character by one.

Even worse, sometimes the boss will insert some characters before, after or within the text. Jiajia wants to write a program to do his job automatically, this program should be fast enough, because there are only few days to Wind’s birthday.
Input
The first line of input file contains initial text.

The second line contains then number of commands n. And the following n lines describe each command. There are two formats of commands:

I ch p: Insert a character ch before the p-th. if p is larger than the current length of text, then insert at end of the text.

Q i j: Ask the length of matching started from the i-th and j-th character of the initial text, which doesn’t include the inserted characters.

You can assume that the length of initial text will not exceed 50000, the number of I command will not exceed 200, the number of Q command will not exceed 20000.
Output
Print one line for each Q command, contain the max length of matching.
Sample Input
abaab
5
Q 1 2
Q 1 3
I a 2
Q 1 2
Q 1 3
Sample Output
0
1
0
3

题意:
给你一个字符串,有两种操作,一种是查询两个位置开始的最大公共子串,另一种是在原字符串第j个字符前加上一个字符。
插入<=200,查询<=20000

计算字符串的hash值,对于每次查询二分长度,插入时则把后面的hash值全重算一遍。

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
const long long LL=1000000009;
long long hsh[60005],pow[60005];
char s[60005];
int now[50005];
int len,m_len;
void get(int l,int len)
{
    for(int i=l;i<len;i++){
        if(i==0){hsh[i]=s[i];continue;}
        hsh[i]=hsh[i-1]*130+s[i];
        hsh[i]%=LL;
    }
}
void query(int x,int y)
{
    int l=1,r=min(len-x+1,len-y+1);
    while(l<r){
        int mid=(l+r)>>1;
        if((hsh[x+mid-1]-hsh[x-1]*pow[mid]%LL+LL)%LL==(hsh[y+mid-1]-hsh[y-1]*pow[mid]%LL+LL)%LL)
            l=mid+1;
        else r=mid;
    }
    printf("%d\n",l-1);
}
void change(char c,int x)
{
    if(x>len) x=len;
    memcpy(s+x+1,s+x,sizeof(char)*(len-x));
    s[x]=c;
    len++;
    get(x,len);

    for(int i=m_len-1;i>=0;i--){
        if(now[i]>=x) now[i]++;
        else break;
    }
}
int main()
{
    scanf("%s",s);
    len=strlen(s);
    m_len=len;
    int n;
    scanf("%d",&n);
    get(0,len);
    pow[0]=1;
    for(int i=1;i<len;i++){
        pow[i]=(pow[i-1]*130)%LL;
        now[i]=i;
    }
    char choice[5];
    int x,y;
    for(int i=0;i<n;i++){
        scanf("%s",choice);
        if(choice[0]=='Q') {
            scanf("%d %d",&x,&y);
            x--;
            y--;
            query(now[x],now[y]);
           // printf("%s\n",s);
        }
        else {
            scanf("%s %d",choice,&x);
            x--;
            change(choice[0],x);
        }
    }
    return 0;
}
### 解决PyCharm无法加载Conda虚拟环境的方法 #### 配置设置 为了使 PyCharm 能够成功识别并使用 Conda 创建的虚拟环境,需确保 Anaconda 的路径已正确添加至系统的环境变量中[^1]。这一步骤至关重要,因为只有当 Python 解释器及其关联工具被加入 PATH 后,IDE 才能顺利找到它们。 对于 Windows 用户而言,在安装 Anaconda 时,默认情况下会询问是否将它添加到系统路径里;如果当时选择了否,则现在应该手动完成此操作。具体做法是在“高级系统设置”的“环境变量”选项内编辑 `Path` 变量,追加 Anaconda 安装目录下的 Scripts 文件夹位置。 另外,建议每次新建项目前都通过命令行先激活目标 conda env: ```bash conda activate myenvname ``` 接着再启动 IDE 进入工作区,这样有助于减少兼容性方面的问题发生概率。 #### 常见错误及修复方法 ##### 错误一:未发现任何解释器 症状表现为打开 PyCharm 新建工程向导页面找不到由 Conda 构建出来的 interpreter 列表项。此时应前往 Preferences/Settings -> Project:...->Python Interpreter 下方点击齿轮图标选择 Add...按钮来指定自定义的位置。按照提示浏览定位到对应版本 python.exe 的绝对地址即可解决问题。 ##### 错误二:权限不足导致 DLL 加载失败 有时即使指定了正确的解释器路径,仍可能遇到由于缺乏适当的操作系统级许可而引发的功能缺失现象。特别是涉及到调用某些特定类型的动态链接库 (Dynamic Link Library, .dll) 时尤为明显。因此拥有管理员身份执行相关动作显得尤为重要——无论是从终端还是图形界面触发创建新 venv 流程均如此处理能够有效规避此类隐患。 ##### 错误三:网络连接异常引起依赖下载超时 部分开发者反馈过因网速慢或者其他因素造成 pip install 操作中途断开进而影响整个项目的初始化进度条卡住的情况。对此可尝试调整镜像源加速获取速度或是离线模式预先准备好所需资源包后再继续后续步骤。 ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值