HDU 4027 - Can you answer these queries?(线段树)

本文介绍了一个涉及区间更新和查询操作的编程问题,其中更新操作要求对指定区间内所有数值进行开方运算,并提供了详细的解题思路及AC代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 15043 Accepted Submission(s): 3529

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output
Case #1:
19
7
6

题意:
给出一个数列, 有更新和区间求和的操作.

更新要求, 区间内的所有数都要开平方.

解题思路:
1.区间更新, 用lazy标记, 如果当前点被更新次数大于5, 那么结果就为1(因为题目给的是1-2^63).

2.单点更新, 如果当前的数已经是1, 那么就没有必要更新了.
即当前区间的区间和为r - l + 1, 那么区间内的所有点都为1, 就不用更新.

AC代码:

#include <stdio.h>
#include <algorithm>
#include <cmath>
#define int long long
#define lson l, mid, rt << 1
#define rson mid+1, r, rt << 1 | 1
using namespace std;
const int maxn = 1e5+5;
int segTree[maxn << 2];

void pushUp(int rt)
{
    segTree[rt] = segTree[rt << 1] + segTree[rt << 1 | 1];
}

void build(int l, int r , int rt)
{
    if(l == r){
        scanf("%lld",&segTree[rt]);
        return ;
    }
    int mid = (l+r) >> 1;
    build(lson);
    build(rson);
    pushUp(rt);
}

void update(int L, int R, int l, int r, int rt)
{
    if(L <= l && R >= r && segTree[rt] == r - l + 1)
        return ;
    if(l == r){
        segTree[rt] = sqrt((double) segTree[rt]);
        return ;
    }
    int mid = (l+r) >> 1;
    if(L <= mid)
        update(L, R, lson);
    if(R > mid)
        update(L, R, rson);
    pushUp(rt);
}

int query(int L, int R, int l, int r, int rt)
{
    if(L <= l && R >= r)
        return segTree[rt];
    int mid = (l+r) >> 1;
    int res = 0;
    if(L <= mid)
        res += query(L, R, lson);
    if(R > mid)
        res += query(L, R, rson);
    return res;
}
void main()
{
    int n;
    int c = 1;
    while(~scanf("%lld",&n)){
        build(1, n, 1);
        int t;
        scanf("%lld",&t);
        printf("Case #%lld:\n",c++);
        while(t--){
            int op;
            int a;
            int b;
            scanf("%lld%lld%lld",&op, &a, &b);
            if(a > b)
                swap(a, b);
            if(op)
                printf("%lld\n",query(a, b, 1, n, 1));
            else
                update(a, b, 1, n, 1);
        }
        putchar('\n');
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值