Ultra-QuickSort
Description ![]() Ultra-QuickSort produces the output Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence. Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input 5 9 1 0 5 4 3 1 2 3 0 Sample Output 6 0 Source |
【思路】
显然是要求逆序对的数目了,由于数据范围过大,而数的数目较小,需要离散化后运用树状数组来维护,前缀和函数sum的含义就是不大于某个数的的数的数目,sum(n)-sum(x)就是大于x的数的数目了。
【代码】
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=500005;
struct point{
int val,pos;
bool operator<(const point &another)const
{
return val<another.val;
}
};
int n;
int id[MAXN],num[MAXN];
point a[MAXN];
int lowbit(int x)
{
return (x&-x);
}
void modify(int x,int add)
{
while(x<=n){
num[x]+=add;
x+=lowbit(x);
}
}
int sum(int x)
{
int ans=0;
while(x>0){
ans+=num[x];
x-=lowbit(x);
}
return ans;
}
int main()
{
while(scanf("%d",&n)==1&&n!=0){
for(int i=1;i<=n;i++){
scanf("%d",&a[i].val);
a[i].pos=i;
}
sort(a+1,a+1+n);
for(int i=1;i<=n;i++)
id[a[i].pos]=i;
memset(num,0,sizeof(num));
long long ans=0;
for(int i=1;i<=n;i++){
modify(id[i],1);
ans+=(sum(n)-sum(id[i]));
}
printf("%lld\n",ans);
}
return 0;
}