拆点最大流-POJ-3281-Dining

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14091 Accepted: 6408

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input
Line 1: Three space-separated integers: N, F, and D
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output
Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint
One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.


题意:
有n头牛,f种实物,d种饮品,每头牛有自己所喜欢的食物和饮品列表,但是每种食物和饮品都只有一人份(一牛份),现在想要知道最多能让多少头牛既能吃到自己喜欢的食物,又能喝到自己爱的饮品。


题解:
样例给的非常水,导致一开始没把牛放进图里就迷迷糊糊写了一发,后来想到限制条件才开始拆点构图。
因为每种食物和饮品都只能算一次,所以从源点引出f条上界为1的边到每种食物,从每种饮品引出一条上界为1的边到源点。
其次,因为每头牛只能被计算一次,所以将每头牛拆为入点和出点两个点,并从入点连一条上界为1的边到出点。
接下来是食物、牛、饮品之间的关系,注意我这里是把牛放在中间的,因为每头牛有自己的方案,所以在构图的时候,牛一定是在食物和饮品之间起到连接作用。
那么对于第i头牛喜欢的食物,从食物点连一条上界为1的边到牛的入点;对于第i头牛喜欢的饮品, 从牛的出点连一条上界为1的边到饮品。
然后从源点到汇点跑一次最大流就可以了。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <utility>
#include <string>

using namespace std;
int n,f,d;
const int MAXN=1100;
int maze[MAXN][MAXN];
int gap[MAXN],dis[MAXN],pre[MAXN],cur[MAXN];
int sap(int start,int end,int nodenum)
{
    memset(cur,0,sizeof(cur));
    memset(dis,0,sizeof(dis));
    memset(gap,0,sizeof(gap));
    int u=pre[start]=start,maxflow=0,aug=-1;
    gap[0]=nodenum;
    while(dis[start]<nodenum)
    {
loop:
        for(int v=cur[u]; v<nodenum; v++)
            if(maze[u][v] && dis[u]==dis[v]+1)
            {
                if(aug==-1 || aug>maze[u][v])aug=maze[u][v];
                pre[v]=u;
                u=cur[u]=v;
                if(v==end)
                {
                    maxflow+=aug;
                    for(u=pre[u]; v!=start; v=u,u=pre[u])
                    {
                        maze[u][v]-=aug;
                        maze[v][u]+=aug;
                    }
                    aug=-1;
                }
                goto loop;
            }
        int mindis=nodenum-1;
        for(int v=0; v<nodenum; v++)
            if(maze[u][v]&&mindis>dis[v])
            {
                cur[u]=v;
                mindis=dis[v];
            }
        if((--gap[dis[u]])==0)break;
        gap[dis[u]=mindis+1]++;
        u=pre[u];
    }
    return maxflow;
}
int main(void)
{
    int num1,num2,tmp;
    ios::sync_with_stdio(false);
    cin >> n >> f >> d;
    int total=f+d+1;
    for(int i=1; i<=n; i++)
    {
        cin >> num1 >> num2;
        for(int j=1; j<=num1; j++)
        {
            cin >> tmp;
            maze[tmp][total+i]=1;
        }
        for(int j=1; j<=num2; j++)
        {
            cin >> tmp;
            maze[total+n+i][tmp+f]=1;
        }
    }
    for(int i=1; i<=n; i++)
        maze[total+i][total+n+i]=1;
    for(int i=1; i<=f; i++)
        maze[0][i]=1;
    for(int i=f+1; i<total; i++)
        maze[i][total]=1;
    cout << sap(0,total,total+1+2*n) << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值