Dungeon Master(逃脱大师)-BFS

本文详细解析了一种迷宫逃脱算法,通过三维迷宫模型,利用深度优先搜索策略寻找最短逃脱路径。文章介绍了输入输出格式,算法实现过程,包括初始化距离标记、使用队列进行节点遍历以及判断边界条件等关键步骤。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

                    Dungeon Master


Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>

using namespace std;
const int  inf=-1;
struct TP
{
    int h,x,y;
    TP(int h, int x, int y):h(h), x(x), y(y) {}
};
int sh,sx,sy,gh,gx,gy;
char a[100][100][100];
int m=0,n=0,h=0;
int d[100][100][100];
int dh[6]= {0,0,0,0,1,-1},dx[6]= {1,0,-1,0,0,0},dy[6]= {0,1,0,-1,0,0};
int dfs()
{
    queue<TP> que;
    for(int k=0; k<h; k++)
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                d[k][i][j]=inf;//初始化所有距离标记
    que.push(TP(sh,sx,sy));//把开始加入队列
    d[sh][sx][sy]=0;//重新定义开头的距离
    while(!que.empty())//队列的循环
    {

        TP p = que.front();//使用队列的开头
        que.pop();//踢出
        if(p.h==gh&&p.x==gx&&p.y==gy) break;//判断是否是结尾
        for(int i=0; i<6; i++)//移动
        {
            int nx=p.x+dx[i],ny=p.y+dy[i],nh=p.h+dh[i];
            if(0 <= nh && 0 <= nx && 0 <= ny && nx < n && ny < m&& nh < h && a[nh][nx][ny]!='#'&&d[nh][nx][ny]==inf)//判断是否是边界以及栅栏
            {
                que.push(TP(nh,nx,ny));//把移动后的加入队列
                d[nh][nx][ny]=d[p.h][p.x][p.y]+1;
            }
        }
    }
    return d[gh][gx][gy];
}
int main()
{
    while(scanf("%d%d%d",&h,&n,&m)!=-1)
    {
        if(h==0&&n==0&&m==0)
            return 0;
        getchar();
        for(int k=0; k<h; k++)
        {
            for(int i=0; i<n; i++)//
            {
                scanf("%s",&a[k][i]);
                for(int j=0; j<m; j++)
                    if(a[k][i][j]=='S')
                        sh=k,sx=i,sy=j;
                    else if(a[k][i][j]=='E')
                        gh=k,gx=i,gy=j;
            }
            getchar();
        }
        int ans=dfs();
        if(ans!=-1)
        printf("Escaped in %d minute(s).\n",ans);
        else
            printf("Trapped!\n");

    }
    return 0;
}






转载于:https://www.cnblogs.com/chinashenkai/p/9451422.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值