1002. A+B for Polynomials (25)
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input2 1 2.4 0 3.2 2 2 1.5 1 0.5Sample Output
3 2 1.5 1 2.9 0 3.2
#include<bits/stdc++.h>
using namespace std;
int i,j,k,n,m;
double num[10000];
int main()
{
int k1,k2;
int a;double b;
scanf("%d",&k1);
for(int i=0;i<k1;i++){
scanf("%d%lf",&a,&b);
num[a]+=b;
}
scanf("%d",&k2);
for(int i=0;i<k2;i++){
scanf("%d%lf",&a,&b);
num[a]+=b;
}
int sum=0;
for(int i=0;i<=1000;i++)
if(num[i]!=0)sum++;
printf("%d",sum);
if(sum>0){
for(int i=1000;i>=0;i--)
if(num[i]!=0)printf(" %d %.1lf",i,num[i]);
}
return 0;
}
#include <iostream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<algorithm>
using namespace std;
int i,j,k,n,m;
int a,b;
int flag;
int k1,k2;
struct node
{
int no;
double num;
};
int main()
{
node p1[2000],p2[2000];
node p[2000];
p1[20].no=-1,p2[20].no=-1;
scanf("%d",&k1);
for(int i=0;i<k1;i++){
scanf("%d %lf",&p1[i].no,&p1[i].num);
}
scanf("%d",&k2);
for(int i=0;i<k2;i++){
scanf("%d %lf",&p2[i].no,&p2[i].num);
}
i=0,j=0,k=0;
while(1){
if(i==k1&&j==k2)break;
if(i==k1||j==k2){
if(i==k1){
p[k].no=p2[j].no;
p[k].num=p2[j].num;
k++,j++;
}
else{
p[k].no=p1[i].no;
p[k].num=p1[i].num;
k++,i++;
}
}
else if(p1[i].no==p2[j].no){
p[k].no=p1[i].no;
p[k].num=p1[i].num+p2[j].num;
k++,j++,i++;
}
else if(p1[i].no>p2[j].no){
p[k].no=p1[i].no;
p[k].num=p1[i].num;
k++,i++;
}
else if(p1[i].no<p2[j].no){
p[k].no=p2[j].no;
p[k].num=p2[j].num;
k++,j++;
}
}
int kk=k;
for(int i=0;i<k;i++){
if(p[i].num==0)kk--;
}
printf("%d",kk);
for(int i=0;i<k;i++){
if(p[i].num==0)continue;
printf(" %d %.1f",p[i].no,p[i].num);
}
return 0;
}