Minimal Ratio Tree
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 8 Accepted Submission(s) : 7
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.
Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.

Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.
Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.
All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].
The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.
All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].
The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.

Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .
Sample Input
3 2 30 20 10 0 6 2 6 0 3 2 3 0 2 2 1 1 0 2 2 0 0 0
Sample Output
1 3 1 2
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<climits>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i++)
#define MS(x,y)memset(x,y,sizeof(x))
#define MC(x,y)memcpy(x,y,sizeof(y))
typedef long long LL;
const int INF=0x7FFFFFFF;
const int low(int x){return x&-x;}
const int M=15+1;
int vis[M],ans[M];
int pre[M],h[M];
double mp[M][M],w[M],mc[M],mr;
int i,j,k,n,m;
double prim()
{
MS(h,0);
int cur;
rep(i,1,n+1)
if(vis[i]){cur=i;break;}
h[cur]=1;
double ws=0,es=0;
rep(i,1,n+1)
if(vis[i]){
mc[i]=mp[cur][i];
pre[i]=cur;ws+=w[i];
}
rep(i,1,m){
cur=-1;
rep(j,1,n+1)
if(vis[j]&&!h[j]){
if(cur==-1||mc[cur]>mc[j])cur=j;
}
es+=mp[cur][cur];
h[cur]=1;
rep(j,1,n+1)
if(!vis[j]&&!h[j])
if(mc[j]>mp[cur][j]){
mc[j]=mp[cur][j];
pre[j]=cur;
}
}
return es/ws;
}
void dfs(int cur,int num)
{
if(num>m)return;
if(cur==n+1){
if(num!=m)return;
double t=prim();
if(t<mr)mr=t,MC(ans,vis);
return;
}
vis[cur]=1;
dfs(cur+1,num+1);
vis[cur]=0;
dfs(cur+1,num);
}
int main()
{
while(~scanf("%d%d",&n,&m),n+m)
{
for(i=1;i<=n;i++)
scanf("%lf",&w[i]);
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
scanf("%lf",&mp[i][j]);
MS(vis,0);
mr=INF;
dfs(1,0);
bool flag=1;
rep(i,1,n+1)
if(ans[i]){
if(!flag)printf(" %d",i);
else {printf("%d",i);flag=0;}
}
printf("\n");
}
return 0;
}