通用版四Q尺取法

本文介绍了一种算法,用于解决给定一个整数序列和一个目标值T,找到序列中一个连续子序列,使得该子序列的和最接近T的问题。通过使用前缀和与二分查找的方法实现了高效求解。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input
5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0
Sample Output
5 4 4
5 2 8
9 1 1
15 1 15
15 1 15


题目大意:给定一个数列和目标数T,求一段子数列满足子数列的和最接近T

尺取法,一开始没思路,感觉尺取没法用,然后想到对前缀和来进行尺取.

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
struct node
{
  int value;
  int id;
} a[100005]={0};
int cmp(const void *a,const void *b)
{
 return (*(int*)a)>(*(int*)b)?1:-1;
}
int main()
{
 int n,k;
 while (1)
 {
   int i;
   scanf("%d%d",&n,&k);
   if ((n==0)&&(k==0)) break;
   a[0].value=0;a[0].id=0;
   for (i=1;i<=n;i++)
   {
    scanf("%d",&a[i].value);
    a[i].value+=a[i-1].value;
    a[i].id=i;
   }
   qsort(a,n+1,sizeof(a[0]),cmp);
   while (k--)
   {
    int ans,l=0,r=1,t,maxl=2100000005,sum,q,e;
    scanf("%d",&t);
    while (r<=n)
    {
     sum=a[r].value-a[l].value;
     if (abs(sum-t)<maxl)
     {
       maxl=abs(sum-t);
       ans=sum;
       q=a[l].id;e=a[r].id;
     }
     if (sum<t) r++;else l++;
     if (l==r) r++;
    }
    if (q>e) {q=q+e;e=q-e;q=q-e;}
    printf("%d %d %d\n",ans,q+1,e);
   }
 }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值