An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the root of the resulting AVL tree in one line.
Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88
题意:
输入平衡二叉树的结点数、结点权值序列;输出平衡二叉树的根结点权值.
思路:
(1)依据给定的条件构建平衡二叉树,输出其根结点权值.
代码:
#include <cstdio>
#include <algorithm>
using namespace std;
struct node{//平衡二叉树存储结构
int data,height;
node *lchild,*rchild;
};
node* newNode(int x){//新建一个平衡二叉树
node* root = new node;
root->data = x;
root->height = 1;
root->lchild = root->rchild = NULL;
return root;
}
int getHeight(node* root){//获取结点高度
if(root==NULL) return 0;
return root->height;
}
void updateHeight(node* &root){//更新结点高度
root->height = max(getHeight(root->lchild),getHeight(root->rchild))+1;
}
int getBalanceFactor(node* root){//获取结点平衡因子
return getHeight(root->lchild)-getHeight(root->rchild);
}
void R(node* &root){//右旋
node* temp = root->lchild;
root->lchild = temp->rchild;
temp->rchild = root;
updateHeight(root);
updateHeight(temp);
root = temp;
}
void L(node* &root){//左旋
node* temp = root->rchild;
root->rchild = temp->lchild;
temp->lchild = root;
updateHeight(root);
updateHeight(temp);
root = temp;
}
void insert(node* &root,int x){//插入权值为x的结点
if(root==NULL){
root = newNode(x);
return;
}
if(root->data>x){
insert(root->lchild,x);
updateHeight(root);
if(getBalanceFactor(root)==2){
if(getBalanceFactor(root->lchild)==1){
R(root);
}else if(getBalanceFactor(root->lchild)==-1){
L(root->lchild);
R(root);
}
}
}else{
insert(root->rchild,x);
updateHeight(root);
if(getBalanceFactor(root)==-2){
if(getBalanceFactor(root->rchild)==-1){
L(root);
}else if(getBalanceFactor(root->rchild)==1){
R(root->rchild);
L(root);
}
}
}
}
node* createAVL(int data[],int n){//创建平衡二叉树
node* root = NULL;
for(int i=0;i<n;i++) insert(root,data[i]);
return root;
}
int main(){
int n;
scanf("%d",&n);
int data[n];
for(int i=0;i<n;i++) scanf("%d",&data[i]);
node* root = createAVL(data,n);
printf("%d\n",root->data);
return 0;
}
PS:
输出结点权值序列的中位数也可以得分.