Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109.
Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
题意:
给定一组整数,在这些整数能够组成的完美序列中,找出包含的整数最多的完美序列,输出这些整数的个数.(完美序列是指序列中最大整数M、最小整数m满足M<=m*p,其中p为给定参数.)
思路:
(1)将给定的一组整数放入数组a[n]中,对数组a排序,构成非递减有序序列;
(2)将数组中元素a[i] (0<=i<n)做为完美序列中最小值m,在a[i+1]~a[n-1]中寻找出第一个大于m*p的元素的位置j,j-i即为完美序列的最大长度.
代码:
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int n,p,a[maxn];
//在[i+1,n-1]范围内查找第一个大于x的数的位置
int binarySearch(int i,long long x){
if(a[n-1]<=x) return n;
int l=i+1,r=n-1,mid;
while(l<r){
mid = (l+r)/2;
if(a[mid]<=x)
l = mid+1;
else
r = mid;
}
return l;
}
int main(){
scanf("%d%d",&n,&p);
for(int i=0;i<n;i++){
scanf("%d",&a[i]);
}
sort(a,a+n);
int ans = 1;
for(int i=0;i<n;i++){
int j = binarySearch(i,(long long)a[i]*p);
ans = max(ans,j-i);
}
printf("%d",ans);
return 0;
}
词汇:
parameter 决定因素,参数