PAT A1085 Perfect Sequence (25分)——二分查找实现

本文介绍了一种算法,用于从给定的整数序列中找出包含最多整数的完美子序列,其中完美序列定义为序列中最大数M和最小数m满足M<=m*p的条件,p为给定参数。通过排序和二分搜索策略,文章提供了完整的代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤10​9) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

题意:

给定一组整数,在这些整数能够组成的完美序列中,找出包含的整数最多的完美序列,输出这些整数的个数.(完美序列是指序列中最大整数M、最小整数m满足M<=m*p,其中p为给定参数.)

思路:

(1)将给定的一组整数放入数组a[n]中,对数组a排序,构成非递减有序序列;
(2)将数组中元素a[i] (0<=i<n)做为完美序列中最小值m,在a[i+1]~a[n-1]中寻找出第一个大于m*p的元素的位置j,j-i即为完美序列的最大长度.

代码:

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 100010;
int n,p,a[maxn];

//在[i+1,n-1]范围内查找第一个大于x的数的位置
int binarySearch(int i,long long x){
	if(a[n-1]<=x) return n;
	int l=i+1,r=n-1,mid;
	while(l<r){
		mid = (l+r)/2;
		if(a[mid]<=x)
			l = mid+1;
		else
			r = mid; 
	}
	return l;
}

int main(){
	scanf("%d%d",&n,&p);
	for(int i=0;i<n;i++){
		scanf("%d",&a[i]);
	}
	sort(a,a+n);
	int ans = 1;
	for(int i=0;i<n;i++){
		int j = binarySearch(i,(long long)a[i]*p);
		ans = max(ans,j-i);
	}
	printf("%d",ans);
	return 0;
} 

词汇:

parameter 决定因素,参数

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值