HDU1018

Big Number


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31414    Accepted Submission(s): 14607




Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 


Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 


Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 


Sample Input
2
10
20
 


Sample Output
7

19


大概题目意思就是,给你一个数,让你求它的阶乘有多少位数。


      要做这个题目,功力要深啊。我开始用求N!的结果的方法来算,但是它的数据链过于太大了,达到了10^7,所以行不通。只能利用其它的方法。
  可以认为:N!=(常数)A * 10^m ,其中A我们不必去管它,这里就直接把他看成1吧。所以   N!= 10^m   ,  两边同时取对数,
  即 :log10 (N!)=m    所以log10(1)+log10(2)+log10(3)+…………+log10(n)=m  。所以 最后的结果对m加1就可以啦;



<span style="font-family: Arial, Helvetica, sans-serif;">#include<iostream></span>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
	int k,l,m;
	double j,i;
	scanf("%d",&l);
	getchar();
	while(l--)
	{
		scanf("%d",&k);
		j=0;
		for(i=2;i<=k;i++)
		j+=log10(i);
		m=int(j)+1;
		printf("%d\n",m);
	}
	return 0;
 } 








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值