素数环问题

A ring is composed of n (even number) circles as shown in diagram.
Put natural numbers 1, 2, . . . , n into each circle separately, and the
sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n ≤ 16)
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the
ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above
requirements.
You are to write a program that completes above process.

Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int N = 10000 + 5;
int a[N];  
bool used[N];
void dfs(int step);
int n,m;
int c[20];
int minx;
int sum = 0,f = 0,h = 0,q = 1;;
bool issu(int s){
    if(s <= 3)
    return true;
    if(s%2==0)
    return false;
    for(int i = 3;i <= sqrt(s);i+=2){
        if(s%i==0)
        return false;
    }
    return true;
}
void dfs(int k){
    if(issu(sum) == false || c[1]!=1){
        return;
    }
    if(k == n+1){
        if(issu(c[k-1]+c[1])==false){
            return;
        }
            for(int i = 1;i < n;i++){
                printf("%d ",c[i]);
            }
                printf("%d",c[n]);
            cout<<"\n";
        	h++;
		}  
    for(int i = 1;i <= n;i++){
        if(used[i]==false){
            c[k] = i;
            if(k!=1)
            sum = c[k] + c[k-1],f++;
            used[i]=true;
            dfs(k+1);
              sum = 0;
            used[i]=false;
        }
    } 
}
int main(){
/*	freopen("1.txt","r",stdin);
	freopen("2.txt","w",stdout);
*/    while(scanf("%d",&n)!=EOF){
    	sum = 0,f = 0;
    	if(h){
	    	cout<<'\n';
		}
    	printf("Case %d:\n",q++);
    	c[1] = 1;
		memset(used,false,sizeof(used));
    	dfs(1);
    }
    return 0; 
}

素数环问题其实就是一个全排列只是把边界条件改一改就行了

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值