0808 poj#1163 The Triangle

本文介绍了一个经典的动态规划问题:给定一个数字三角形,找出从顶点到底边的最大路径和。通过逆向思维,从底部向上逐层更新路径最大值,最终在顶部得到整个问题的解。该方法巧妙地避免了重复计算,显著提高了算法效率。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

摘要
-使用动态规划的思想,避免不必要重复计算。
原题目摘要
- POJ - 1163
The Triangle

-
 
 
    7
    3   8
    8   1   0
    2   7   4   4
    4   5   2   6   5
 
    (Figure 1)
 
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
    Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
 
    5
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5
 
Sample Output
 
    30


题目理解
-题目描述的从根出发 但这样出发并不能找到问题的子结构。以最后一行出发的话就可以发现子结构。可用递归可用递推。
注意
-动态规划的进行的方向 不应该是状态增加的方向,进行的方向要能达到边界。
题目中的数据只用一次的可以在计算后重新保存其他的值,达到内存的合理利用。
日期
-2017 0808
附加
-
代码
1
#include <cstdio>
2
#include <algorithm>
3
#include <iostream>
4
#include <memory>
5
using namespace std;
6
#define MAX 101
7
int D[MAX][MAX];
8
9
10
11
int main(){
12
13
    int r;
14
    scanf("%d",&r);r+=1;
15
    for(int i=0;i<r;i++){
16
        for(int j=0;j<i;j++){
17
            scanf("%d",&D[i][j]);
18
        }
19
    }
20
    
21
    
22
    for(int i=r-2;i>0;i--){
23
        for(int j=0;j<i;j++){
24
            D[i][j]=max(D[i+1][j],D[i+1][j+1])+D[i][j];
25
        }
26
    }
27
    printf("%d",D[1][0]);
28
    return 0;
29
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值