Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 7458 | Accepted: 3955 |
Description
Given an undirected weighted graph G, you should find one of spanning trees specified as follows.
The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E has its weight w(e).
A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.

Figure 5: A graph G and the weights of the edges
For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

Figure 6: Examples of the spanning trees of G
There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.
Your job is to write a program that computes the smallest slimness.
Input
The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.
n | m | |
a1 | b1 | w1 |
⋮ | ||
am | bm | wm |
Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak andbk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight ofek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).
Output
For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.
Sample Input
4 5 1 2 3 1 3 5 1 4 6 2 4 6 3 4 7 4 6 1 2 10 1 3 100 1 4 90 2 3 20 2 4 80 3 4 40 2 1 1 2 1 3 0 3 1 1 2 1 3 3 1 2 2 2 3 5 1 3 6 5 10 1 2 110 1 3 120 1 4 130 1 5 120 2 3 110 2 4 120 2 5 130 3 4 120 3 5 110 4 5 120 5 10 1 2 9384 1 3 887 1 4 2778 1 5 6916 2 3 7794 2 4 8336 2 5 5387 3 4 493 3 5 6650 4 5 1422 5 8 1 2 1 2 3 100 3 4 100 4 5 100 1 5 50 2 5 50 3 5 50 4 1 150 0 0
Sample Output
1 20 0 -1 -1 1 0 1686 50
Source
题意是要找出构成所有树中最大边与最小边的差值最小是多少,首先对边从小到大排序,用kruskal让他们依次生成一些树(从第一条边开始,然后从第二条边开始。。。。),生成一棵树需要n-1条边,所以最多能生成m-n+1棵树,而且每棵树生成后都要判断一下是否是完全连通的。当第一次生成树时先判断一次是否连通,如果不连通则说明后面的树更不可能连通,此时就直接输出-1并退出。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 1e8
using namespace std;
int fa[110];
int n,m;
struct node
{
int u,v,w;
}e[110000];
bool cmp(node n1,node n2)
{
return n1.w<n2.w;
}
int Find(int x)
{
if(x!=fa[x])
x=Find(fa[x]);
return x;
}
int kruskal(int j)
{
for(int i=1;i<=n;i++)
{
fa[i]=i;
}
int st=e[j].w,en=0;
for(int i=j;i<m;i++)
{
int x=Find(e[i].u);
int y=Find(e[i].v);
if(x!=y)
{
en=max(en,e[i].w);
fa[x]=y;
}
}
int tem=Find(1),flag=0;
for(int i=2;i<=n;i++)
{
if(Find(i)!=tem)
{
flag=1;
break;
}
}
if(flag) return -1;
else return en-st;
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
int ans=inf;
if(n==0&&m==0) break;
for(int i=0;i<m;i++)
scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
sort(e,e+m,cmp);
int a=kruskal(0); //从第一条边开始生成一棵树,判断一下这些点是否连通
if(a==-1) {
printf("-1\n");
continue;
}
ans=min(ans,a);
for(int j=1;j<=m-n+1;j++)
{
int a=kruskal(j);
if(a!=-1) ans=min(a,ans);
}
printf("%d\n",ans);
}
return 0;
}