uva 11235 Frequent values

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source

Ulm Local 2007

解析
RMQ。cnt[i]表示在位置i处,前面有多少与这个数相同的数。对于询问a,b找cnt[a]到cnt[b]之间的最大值即可。
询问时有这样一个处理
for(int i=1;i<=Q;i++)
	{
		int a,b; scanf("%d%d",&a,&b);
		int t=a;
		while(t<=b && cnt[t]==cnt[t-1]) t++;
		printf("%d\n",max(RMQ(t,b),t-a));
	}
记得初始化cnt[0]=-INF

#include<cstdio>
#include<algorithm>

using namespace std;

#define LOCAL
int f[200100][31],cnt[200100],N,Q;

void readdata()
{
	scanf("%d",&Q);
	cnt[0]=-0x3f3f3f3f;
	scanf("%d",&cnt[1]); f[1][0]=1;
	for(int i=2;i<=N;i++)
	{
		scanf("%d",&cnt[i]);
		if(cnt[i]>cnt[i-1]) f[i][0]=1;
		else f[i][0]=f[i-1][0]+1;
	}
}

void RMQ_ST()
{
	for(int i=1;(1<<i)<N;i++)
		for(int j=1;(j+(1<<i)-1)<=N;j++)
			f[j][i]=max(f[j][i-1],f[j+(1<<(i-1))][i-1]);
}
int RMQ(int a,int b)
{
	if(a==b) return 1;
	int t=0;
	while(b-a+1>(1<<t)) t++; t--;
	return max(f[a][t],f[b-(1<<t)+1][t]);
}

void Ask()
{
	for(int i=1;i<=Q;i++)
	{
		int a,b; scanf("%d%d",&a,&b);
		int t=a;
		while(t<=b && cnt[t]==cnt[t-1]) t++;
		printf("%d\n",max(RMQ(t,b),t-a));
	}
}

int main()
{
	while(scanf("%d",&N))
	{
		if(N==0) break;
		readdata();
		RMQ_ST();
		Ask();
	}
#ifdef LOCAL
	while(1);
#endif
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值