题目描述:
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
输入:
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.
输出:
If kiki wins the game printf "Wonderful!", else "What a pity!".
样例输入:
5 3
5 4
6 6
0 0
样例输出:
What a pity!
Wonderful!
Wonderful!
代码:
#include<stdio.h>
int main()
{
int n,m;
while(scanf("%d%d",&n,&m))
{
if(n==0||m==0) break;
if(n%2==0||m%2==0)
{
printf("Wonderful!\n");
}
else
printf("What a pity!\n");
}
return 0;
}
分析:本题其实是一道关于博弈的题目,从右下角往左上角推导,当n=m=2即为2*2方阵时,无论kiki或ZZ谁先进入这个2*2方阵就意味着谁输了,根据这一思路往上推得谁先处于n和m都为奇数的方格时,她就输了。