Advanced Fruits(链接:http://acm.hdu.edu.cn/showproblem.php?pid=1503)

本文介绍了一种算法,该算法能够为两种水果基因组合创造的新品种生成最短且包含原有名称的名称。通过使用动态规划求解最长公共子序列问题,确保了新名称既反映了原始水果的特点又能保持最简短。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Advanced Fruits

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 9
Special Judge
Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. Input is terminated by end of file.
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
  
  
apple peach ananas banana pear peach
 

Sample Output
  
  
appleach bananas pearch
 

Source
University of Ulm Local Contest 1999
#include<cstdio>
#include<cstring>
const int max=1010;
char a[max],b[max];
int dp[max][max],p[max][max];
int la,lb;
void lcs()
{
	int i,j;
	memset(dp,0,sizeof(dp));
	for(i=0;i<=la;++i)
	p[i][0]=1;
	for(i=0;i<=lb;++i)
	p[0][i]=2;
	for(i=1;i<=la;++i)
	{
		for(j=1;j<=lb;++j)
		{
			if(a[i-1]==b[j-1])
			{
				dp[i][j]=dp[i-1][j-1]+1;
				p[i][j]=0;
			}
			else if(dp[i-1][j]>=dp[i][j-1])
			{
				dp[i][j]=dp[i-1][j];
				p[i][j]=1;
			}
			else
			{
				dp[i][j]=dp[i][j-1];
				p[i][j]=2;
			}
		}
	}
}

void printlcs(int i,int j)
{
	if(i==0&&j==0)
	return ;
	if(p[i][j]==0)
	{
		printlcs(i-1,j-1);
		printf("%c",b[j-1]);
		//printf("%c",a[i-1]);
	}
	else if(p[i][j]==1)
	{
		printlcs(i-1,j);
		printf("%c",a[i-1]);
	}
	else
	{
		printlcs(i,j-1);
		printf("%c",b[j-1]);
	}
}
int main()
{
	while(~scanf("%s%s",a,b))
	{
		la=strlen(a);
		lb=strlen(b);
		lcs();
		printlcs(la,lb);
		printf("\n");
	}
	return 0;
}

内容概要:集成测试是确保软件质量的关键环节,它在单元测试基础上验证模块间的交互和协作。文章详细介绍了集成测试的目的、重要性、流程步骤、策略与方法以及常见问题的解决办法。集成测试不仅验证模块接口的正确性,还确保系统的整体功能和性能符合预期。文章通过一个电商系统的实际案例,展示了集成测试在发现和解决问题中的具体应用。最后,展望了集成测试未来的发展趋势,如自动化测试、云计算、大数据和人工智能技术的应用。 适合人群:软件开发人员、测试工程师、项目经理及相关技术人员。 使用场景及目标:①了解集成测试在整个软件开发生命周期中的作用和重要性;②掌握集成测试的详细流程,包括测试计划制定、环境搭建、用例设计、执行与记录、缺陷管理和回归测试、测试总结与报告;③学习集成测试的不同策略(自顶向下、自底向上、混合策略)和方法(黑盒测试、白盒测试、模拟测试),并理解其适用场景;④掌握常见问题(接口不匹配、数据传递错误、性能瓶颈)的解决办法。 其他说明:本文不仅提供了集成测试的理论知识,还结合实际案例进行详细讲解,帮助读者更好地理解和应用集成测试技术。未来集成测试将受益于自动化测试、云计算、大数据和人工智能技术的发展,测试人员应不断学习新技术,优化测试流程,提高软件质量和效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值