POJ 2406 Power Strings KMP算法

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 49787 Accepted: 20747

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

[Submit]   [Go Back]   [Status]   [Discuss]


Link: http://poj.org/problem?id=2406



这里给出一个定理

假设S的长度为len,则S存在循环子串,当且仅当,len可以被len - next[len]整除,最短循环子串为S[len - next[len]]


AC Code:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1000000+50;
int f [maxn];
int ls,la;
void getfill(char* s)
{
    memset(f,0,sizeof(f));
    for(int i=1;i<ls;i++)
    {
        int j=f[i];
        while(j && s[i]!=s[j])
            j=f[j];
        f[i+1]=(s[i]==s[j])?j+1:0;
    }
}
int find(char* a,char* s)
{
    int ans=0;
    getfill(s);int j=0;
    for(int i=0;i<la;i++)
    {
        while(j && a[i]!=s[j])
            j=f[j];
        if(a[i]==s[j])
            j++;
        if(j==ls){
            ans++;
        }
    }
    return ans;
}
int main()
{
    char str[maxn];
    while(~scanf("%s",str)){
        if(str[0]=='.') break;
        ls=strlen(str);
        getfill(str);
        if(ls%(ls-f[ls])==0) printf("%d\n",ls/(ls-f[ls]));
        else printf("1\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值