Power Strings
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input abcd aaaa ababab . Sample Output 1 4 3 Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source |
[Submit] [Go Back] [Status] [Discuss]
Link: http://poj.org/problem?id=2406
这里给出一个定理:
假设S的长度为len,则S存在循环子串,当且仅当,len可以被len - next[len]整除,最短循环子串为S[len - next[len]]
AC Code:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1000000+50;
int f [maxn];
int ls,la;
void getfill(char* s)
{
memset(f,0,sizeof(f));
for(int i=1;i<ls;i++)
{
int j=f[i];
while(j && s[i]!=s[j])
j=f[j];
f[i+1]=(s[i]==s[j])?j+1:0;
}
}
int find(char* a,char* s)
{
int ans=0;
getfill(s);int j=0;
for(int i=0;i<la;i++)
{
while(j && a[i]!=s[j])
j=f[j];
if(a[i]==s[j])
j++;
if(j==ls){
ans++;
}
}
return ans;
}
int main()
{
char str[maxn];
while(~scanf("%s",str)){
if(str[0]=='.') break;
ls=strlen(str);
getfill(str);
if(ls%(ls-f[ls])==0) printf("%d\n",ls/(ls-f[ls]));
else printf("1\n");
}
return 0;
}