For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
kmp的next函数,next[i],表示以i结尾的子串的后缀与前缀匹配的最大长度为next[i]
(假定串从1开始)
这里主要是要求循环节大于1,首先假定一个长度为n的子串,如果有3个循环节长度为k,那么next[n]的大小应为2k,即前缀与后缀的最大匹配应为2k,可以去尝试画个图这里不解释了。于是对于某个子串,每次都取next[i],如果串的长度n是n - next[i]的2倍及以上,则该子串即是符合条件的。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <queue>
#include <cstring>
using namespace std;
int n;
char a[1000005];
int f[1000005];
void solve(){
int j = 0;
f[0] = f[1] = 0;
for(int i = 1;i < n;++i){
while(j && a[i] != a[j]){
j = f[j];
}
f[i + 1] = a[i] == a[j] ? ++j : 0;
}
/*for(int i = 0;i <= n;++i){
cout << f[i] << " ";
}
cout << endl;*/
for(int i = 1;i < n;++i){
int m = i + 1;
if(m % (m - f[m]) == 0){
int t = m / (m - f[m]);
if(t > 1){
cout << m << " " << t << endl;
}
}
}
}
int main(){
for(int i = 1;;i++){
scanf("%d",&n);
if(n == 0){
break;
}
scanf("%s",a);
cout << "Test case #" << i << endl;
solve();
cout << endl;
}
return 0;
}