第二周下最短路spfa算法(Candies POJ - 3159)

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input
The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output
Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input
2 2
1 2 5
2 1 4
Sample Output
5
Hint
32-bit signed integer type is capable of doing all arithmetic.

题意:
你有一些糖果,需要把他们分给孩子们,但是这些小孩有自己的想法,他们认为自己的糖果不应该比他认为的那个小孩少c个,不然会不开心,让你求出在让所有小孩都满意的前提下,第一个小孩得到的糖果与第二个得到的糖果数差值最大(这点题目描述有误)

题解:
最短路spfa模板,利用邻接表优化
dis数组表示第i个小朋友的糖果数比第一个小朋友多的个数
代码:

#include"stdio.h"
#include"string.h"
#include"queue"
#include"stack"
#include"algorithm"
using namespace std;
const int inf=0x3f3f3f;
int m,n,cnt;
int st[100010],book[100010],first[100010],next[100010],w[100010],dis[100010],to[100010];
void add(int a,int b,int c)//建立邻接表
{
	to[++cnt]=b;
	w[cnt]=c;
	next[cnt]=first[a];
	first[a]=cnt;
}
int spfa()//核心算法
{
	int top=0,i,u,v;
	memset(book,0,sizeof(book));
	memset(dis,inf,sizeof(dis));
	book[1]=1;
	dis[1]=0;
	st[++top]=1;//将一号小朋友入队列
	while(top!=0)
	{
		u=st[top];//每次将队列中的最后一个小朋友出队列
		top--;
		book[u]=0;
		for(i=first[u];i;i=next[i])//遍历和小朋友u有关系的小朋友
		{
			v=to[i];
			if(dis[v]>dis[u]+w[i])//如果此时小朋友v的糖果数大于了小朋友u的糖果数加上小朋友u的期望值,则让小朋友v的糖果数等于小朋友u的糖果数加上小朋友u的期望值
			{
				dis[v]=dis[u]+w[i];
				if(!book[v])
				{
					st[++top]=v;
					book[v]=1;
				}
			}
		}
	}
	return dis[n];
}
int main()
{
	int i,a,b,c;
	cnt=0;
	scanf("%d %d",&n,&m);
	for(i=0;i<m;i++)
	{
		scanf("%d %d %d",&a,&b,&c);
		add(a,b,c);
	}
	printf("%d",spfa());
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值