题目大意:所给数n,去掉最后一位数a,并减去5*a所得的值是否能被17整除?
Theorem: If you drop the last digit d of an integer n (n10), subtract 5d from the remaining integer, then the difference is a multiple of 17 if and only if n is a multiple of 17.
For example, 34 is a multiple of 17, because 3-20=-17 is a multiple of 17; 201 is not a multiple of 17, because 20-5=15 is not a multiple of 17.
Given a positive integer n, your task is to determine whether it is a multiple of 17.
Input
There will be at most 10 test cases, each containing a single line with an integer n ( 1

Output
For each case, print 1 if the corresponding integer is a multiple of 17, print 0 otherwise.Sample Input
34 201 2098765413 1717171717171717171717171717171717171717171717171718 0
Sample Output
1 0 1 0
#include<stdio.h>
#include<string.h>
#define M 205
char s[M];
int a[M];
int main(){
int i,n,ans;
while(scanf("%s",s) && s[0]!='0'){
ans=0;
n=strlen(s);
for(i=0;i<n;i++){
a[i]=s[i]-'0';
}
for(i=0;i<n-1;i++){
ans=ans*10+a[i];
ans=ans%17;
}
ans=(ans-a[i]*5)%17;
if(ans) puts("0");
else puts("1");
}
return 0;
}
/*
34
201
2098765413
1717171717171717171717171717171717171717171717171718
0
Sample Output
1
0
1
0
*/