【PAT甲级】1008 Elevator (20 分)

本文介绍了一个简单的电梯调度算法模拟问题,电梯在多个楼层间上下移动,每次停靠需要一定时间。通过模拟电梯在一系列楼层请求中的移动过程,计算并输出完成所有请求所需的总时间。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

 【翻译】:输入N,代表电梯会在接下来的N个楼层停顿,电梯本来在0层,上升一层需要6s,下降一层需要4s,在每一层停5s,运行完毕后不必去0层,输出总共花的时间

【思路】:模拟就完事儿了

#include <iostream>
using namespace std;
int a[100000];

int main(){
	int n,sum = 0;
	cin>>n;
	for(int i = 0; i < n; i++){
		cin>>a[i];
	}
	sum = (a[0] - 0) * 6 + 5;
	for(int i = 1; i < n; i++){
		if(a[i] > a[i - 1]){
			sum += (a[i] - a[i - 1]) * 6 + 5;
		}else{
			sum += (a[i - 1] - a[i]) * 4 + 5;
		}
	}
	cout<<sum<<endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值