1052 Linked List Sorting

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−105,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

代码 

#include <iostream>
#include <algorithm>
#include <unordered_map>
#include <vector>

using namespace std;
struct node{
    string address;
    int key;
    string next;
    bool operator< (const node& t) const{
        return key < t.key;
    }
};

unordered_map<string, node> location_map;
vector<node> nodes;

int main()
{
    int n;
    char head[10];
    scanf("%d%s", &n, head);
    char address[10], next[10];
    int key;
    while(n--){
        scanf("%s%d%s", address, &key, next);
        location_map[address] = {address, key, next};
    }
    
    for(string i = head; i != "-1"; i = location_map[i].next) nodes.push_back(location_map[i]);
    
    printf("%d ", nodes.size());
    if(nodes.empty()) puts("-1");
    else{
        sort(nodes.begin(), nodes.end());
        printf("%s\n", nodes[0].address.c_str());
        for(int i = 0; i < nodes.size(); i++){
            if(i + 1 == nodes.size()) printf("%s %d -1\n", nodes[i].address.c_str(), nodes[i].key);
            else printf("%s %d %s\n", nodes[i].address.c_str(), nodes[i].key, nodes[i+1].address.c_str());
        }
    }
    
    return 0;
}

总结

1. 输入输出的优化

2. c字符串的转换

3. 用映射来实现链表的存储与排序(核心)

### C++ STL List Usage and Examples In the context of C++, `std::list` is a container that supports constant time insertions and deletions from anywhere within the sequence. This makes it particularly useful when frequent insertion or deletion operations are required. #### Declaration and Initialization A list can be declared using different methods: ```cpp #include <iostream> #include <list> int main() { std::list<int> my_list = {1, 2, 3}; // Initialize with values // Add elements to the end of the list my_list.push_back(4); // Print all elements in the list for (auto& elem : my_list) { std::cout << elem << " "; } } ``` #### Common Operations on Lists Adding an element at any position involves specifying where exactly one wants to add this new item: ```cpp // Inserting before specific iterator location my_list.insert(my_list.begin(), 0); // Inserts '0' as first element ``` Removing items also has multiple options available depending upon what needs removal – either by value or through iterators pointing towards those positions which need erasing: ```cpp // Remove all occurrences of a particular value my_list.remove(2); // Erase single occurrence pointed by iterator auto pos = my_list.begin(); pos++; // Move past beginning my_list.erase(pos); ``` Checking whether two lists contain identical sequences without considering their order might involve sorting both collections beforehand followed by comparison via equality operator (`==`) provided they support such operation directly out-of-the-box like so: ```cpp if (sorted_copy_of_my_list == another_sorted_list) { // Both have same contents regardless of original ordering. } ``` For more advanced manipulations including merging sorted ranges into destination containers while preserving relative orders among equal keys during merge process etc., refer standard library documentation regarding algorithms operating over bidirectional iterators since these apply equally well here too due to nature how linked structures internally manage memory allocation/deallocation patterns under hood[^1].
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值