1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include <iostream>
using namespace std;

const int LEN = 1010;
double a[LEN], b[LEN], sum[LEN];

int main() {
    int n, maxTop = 0;
    cin >> n;
    while( n -- ){
        int top;
        double base;
        cin >> top >> base;
        if(top > maxTop || !maxTop) maxTop = top;
        a[top] = base;
    }
    cin >> n;
    while( n-- ){
        int top;
        double base;
        cin >> top >> base;
        if(top > maxTop || !maxTop) maxTop = top;
        b[top] = base;
    }
    int cnt = 0;
    for(int i = maxTop; i >= 0 ; i-- ){
        sum[i] = a[i] + b[i];
        if(sum[i]) cnt ++; 
    }
    cout << cnt;
    for(int i = maxTop; i >= 0 ; i-- ){
        if(sum[i]) printf(" %d %.1lf", i , sum[i]);
    }
	return 0;
}

总结

1. 简单的多项式问题,只需要将对应指数的系数相加后输出即可。

2. 一般考虑开辟最大数组来存储所有系数,然后筛选出有用的数据输出即可。关键是筛选。

1002 A+B for Polynomials 是一道编程题目,通常是在考察Java中处理多项式加法的问题。在这个问题中,你需要编写一个程序,让用户输入两个多项式的系数(如a_n*x^n + a_{n-1}*x^{n-1} + ... + a_1*x + a_0的形式),然后计算它们的和,并按照同样的形式表示出来。 在Java中,你可以创建一个`Polynomial`类,包含一个数组来存储系数和最高次数的信息。用户输入的每个多项式可以被解析成这样的结构,然后通过遍历并累加系数来完成加法操作。最后,将结果转换回字符串形式展示给用户。 以下是简化版的代码示例: ```java class Polynomial { int[] coefficients; int degree; // 构造函数,初始化数组 public Polynomial(int[] coeffs) { coefficients = coeffs; degree = coefficients.length - 1; } // 加法方法 Polynomial add(Polynomial other) { Polynomial result = new Polynomial(new int[coefficients.length + other.coefficients.length]); for (int i = 0; i < coefficients.length; ++i) { result.coefficients[i] += coefficients[i]; } for (int i = 0; i < other.coefficients.length; ++i) { result.coefficients[i + coefficients.length] += other.coefficients[i]; } result.degree = Math.max(degree, other.degree); return result; } @Override public String toString() { StringBuilder sb = new StringBuilder(); if (degree >= 0) { for (int i = degree; i >= 0; --i) { sb.append(coefficients[i]).append('*x^').append(i).append(" + "); } // 移除最后一个 " + " sb.setLength(sb.length() - 2); } else { sb.append("0"); } return sb.toString(); } } // 主函数示例 public static void main(String[] args) { Polynomial poly1 = new Polynomial(...); // 用户输入第一个多项式的系数 Polynomial poly2 = new Polynomial(...); // 用户输入第二个多项式的系数 Polynomial sum = poly1.add(poly2); System.out.println("Result: " + sum); } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值