hdu2609---How many

Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include ‘0’,’1’).

Output
For each test case output a integer , how many different necklaces.

Sample Input

4 0110 1100 1001 0011 4 1010 0101 1000 0001

Sample Output

1 2

Author
yifenfei

Source
奋斗的年代

Recommend
yifenfei | We have carefully selected several similar problems for you: 2608 1131 2572 1130 2610

把每一个串用最小表示法表示,然后统计出不同的字符串的个数

/*************************************************************************
    > File Name: hdu2609.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年02月17日 星期二 22时06分29秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int N = 10010;
const int M = 110;
char str[N][M];
char s[M];
set <string> st;

void minway (char str[])
{
    int len = strlen (str);
    int i = 0;
    int j = 1;
    int k = 0;
    while (i < len && j < len && k < len)
    {
        int t = str[(i + k) % len] - str[(j + k) % len];
        if (!t)
        {
            ++k;
        }
        else
        {
            if (t > 0)
            {
                i += k + 1;
            }
            else
            {
                j += k + 1;
            }
            k = 0;
            if (i == j)
            {
                ++j;
            }
        }
    }
    int start = min (i, j);
    for (int i = 0; i < len; ++i)
    {
        s[i] = str[(i + start) % len];
    }
    s[len] = '\0';
    st.insert(s);
}

int main ()
{
    int n;
    while (~scanf("%d", &n))
    {
        st.clear();
        for (int i = 1; i <= n; ++i)
        {
            scanf("%s", str[i]);
            minway(str[i]);
        }
        int size = st.size();
        printf("%d\n", size);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值