ROADS

本文介绍了一个寻找从城市1到城市N的最短路径的问题,考虑到过路费的限制。通过深度优先搜索和剪枝策略,文章提供了一种解决此问题的算法实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

ROADS

总时间限制:
1000ms
内存限制:
65536kB

描述
N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

输入
The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :

    S is the source city, 1 <= S <= N
    D is the destination city, 1 <= D <= N
    L is the road length, 1 <= L <= 100
    T is the toll (expressed in the number of coins), 0 <= T <=100


Notice that different roads may have the same source and destination cities. 

输出
The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.
样例输入

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

样例输出

11

关于这条题目,我后面有空会把视频补上

//by Gary
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
//使用邻接表
int K,N,R;//钱数,城市数,道路数
struct Road
{
    int d,L,t;//终点,长度,过路费
};
vector<vector<Road>> G(150);
int midL[150][10100];
int minLen;
int totalLen;
int totalCost;
bool visited[150];
void dfs(int s)//从s出发
{
    if(s==N)
    {//起电=终点
        minLen=min(minLen,totalLen);
        return ;
    }
    for(int i=0;i<G[s].size();++i)
    {
        Road r=G[s][i];
        //看看钱够不够
        if(totalCost+r.t >K)//可行性剪枝
            continue;

        if(!visited[r.d])//没走过
        {
            if(totalLen+r.L>=minLen)//最优性剪枝
                continue;
            if(midL[r.d][totalCost+r.t]<=totalLen+r.L)
                continue;
            midL[r.d][totalCost+r.t]=totalLen+r.L;
            totalLen+=r.L;
            totalCost+=r.t;
            visited[r.d]=1;
            dfs(r.d);
            //撤销
            visited[r.d]=0;
            totalCost-=r.t;
            totalLen-=r.L;
        }
    }
}

int main()
{
    cin>>K>>N>>R;
    for(int i=0;i<R;++i)
    {
        int s;
        Road r;
        cin>>s>>r.d>>r.L>>r.t;
        if(s!=r.d)
        G[s].push_back(r);//加到邻接表里面
    }
    memset(visited,0,sizeof(visited));
    totalLen=0;
    totalCost=0;
    minLen=1<<30;
    visited[1]=1;
        for(int i=0;i<150;++i)
        for(int j=0;j<10100;++j)
        midL[i][j]=1<<30;
    dfs(1);
    for(int i=0;i<150;++i)
        for(int j=0;j<10100;++j)
        midL[i][j]=1<<30;
    if(minLen<(1<<30))
    {
        cout<<minLen<<endl;
    }

    else cout<<"-1"<<endl;
    return 0;
}

学会程序和算法,走遍天下都不怕
在这里插入图片描述肇庆七星岩

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值