Leftmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 19262 Accepted Submission(s): 7632
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
2 3 4
Sample Output
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
#include<sstream>
#include<cstdlib>
#include<map>
const int N =1005;
using namespace std;
int main(){
int n,t;
long long x;
scanf("%d",&t);
for(int i =0;i<t;i++){
scanf("%d",&n);
double m = n*log10((double)n);
double r = m - (long long)m;//取小数部分
r = pow(10.0,r);
cout<<(int)r<<endl;
}
return 0;
}