Background
Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.
This problem involves building and traversing binary trees.
The Problem
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.
In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.
For example, a level order traversal of the tree
is: 5, 4, 8, 11, 13, 4, 7, 2, 1.
In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where Lindicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to becompletely specified if every node on all root-to-node paths in the tree is given a value exactly once.
The Input
The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.
All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.
The Output
For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.
Sample Input
(11,LL) (7,LLL) (8,R) (5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) () (3,L) (4,R) ()
Sample Output
5 4 8 11 13 4 7 2 1 not complete
这道题牵扯到一些知识:
1.构造函数。类或结构体中的构造函数永远没有返回值,也不用写void,例如下面这个构造函数:
struct Point
{
int x,y;
Point(int x=0,int y=0):x(x),y(y){}
}
构造函数是在声明变量时用的,每当定义一个Point变量,就要调用构造函数来赋值。上面是一种简化写法,如果没有指明参数,就按0处理。如Point a,b(1,2),a.x=0,
a.y=0;b.x=1,b.y=2。
2.sscanf 将字符串中的指定类型的字符读入到指定位置,遇到非指定类型停止,下一次从停止的位置开始读。
3.strchr 找出字符串中的指定字符并返回它的地址。
4.new 为指定类型开辟一个足以盛放它的空间。
5.delete 析构函数,释放占用的内存。
下面的代码是用指针来实现的,二叉树的层次遍历(bfs)区别于深度遍历,深度遍历是递归实现,而层次遍历则用queue和vector就可以实现。方法是:每次出队一个结点,就把它的左右结点入队,并把出队的结点压入vector中。代码如下:
#include<cstdio> #include<vector> #include<queue> #include<cstring> using namespace std; const int maxn=300; bool failed; vector<int> ans; struct Node {
bool have_value; int v; Node* left,* right; Node():have_value(false),left(NULL),right(NULL){}
}; //分号不要漏
Node* root;
Node* new_node() { return new Node(); } void add_node(int v,char* s) { Node* u=root; for(int i=0;i<strlen(s);i++) { if(s[i]=='L') { if(u->left==NULL) u->left=new_node(); u=u->left; } if(s[i]=='R') { if(u->right==NULL) u->right=new_node(); u=u->right; } } if(u->have_value) failed=true; u->v=v; u->have_value=true; } void remove_tree(Node* u) { if(u==NULL) return; remove_tree(u->left); remove_tree(u->right); delete u; } bool read() { failed=false; remove_tree(root); root=new_node(); char s[maxn]; int v; for(;;) { if(scanf("%s",s)!=1) return false; if(!strcmp(s,"()")) break; sscanf(&s[1],"%d",&v); add_node(v,strchr(s,',')+1); } return true; } bool bfs(vector<int> &ans) { ans.clear(); queue<Node*> q; q.push(root); while(!q.empty()) { Node* u=q.front();q.pop(); if(u->left!=NULL) q.push(u->left); if(u->right!=NULL) q.push(u->right); if(!u->have_value) return false; ans.push_back(u->v); } return true; } int main() { while(read()) { if(!bfs(ans)) failed=true; if(failed) { printf("not complete\n"); } else { for(int i=0;i<ans.size();i++) //注意输出格式,是每两个数字之间有空格。 { if(i!=0) printf(" "); printf("%d",ans[i]); } printf("\n"); } } return 0; }