【打CF,学算法——三星级】CF Gym 100548K Last Denfence

该博客介绍了如何利用辗转相除法来解决Codeforces(CF)比赛题目Last Defence。题目要求计算序列S中不同数值的数量,S由A和B定义,通过连续取绝对差值生成。博客提供了样例输入和输出,并解释了通过辗转相除法优化计算的方法,避免了模拟过程导致的超时问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

【CF简介】

提交链接:Last Denfence


题面:

 Last Defence
Description
    Given two integers A and B. Sequence S is defined as follow:
    • S0 = A
    • S1 = B
    • Si = |Si−1 − Si−2| for i ≥ 2
    Count the number of distinct numbers in S.
Input
    The first line of the input gives the number of test cases, T. T test cases follow. T is about
    100000.
    Each test case consists of one line - two space-separated integers A, B. (0 ≤ A, B ≤ 1018).
Output
    For each test case, output one line containing “Case #x: y”, where x is the test case
    number (starting from 1) and y is the number of distinct numbers in S.
Samples
Sample Input 

   2
  7 4
  3 5

Sample Output
Case #1: 6
Case #2: 5


解题:

    过程便是辗转相减法,然而模拟这个过程会超时,改进为辗转相除法。直接拿大的数除小的数,即需要减的次数,加到结果中,最后结果便是答案。


代码:

#include <iostream>
using namespace std;
int main()
{
	long long int a,b,n,ans,tmp;
	cin>>n;
	for(int i=1;i<=n;i++)
	{
	cout<<"Case #"<<i<<": ";
	  ans=0;
      cin>>a>>b;    
	  if(a==0&&b==0)
		 {
			 cout<<"1\n";
			 continue;
		 }
	   if(a==0||b==0)
		  {
			  cout<<"2\n";
			  continue;
		  }
	  while(b)
	  {
		  ans+=a/b;
		  tmp=b;
		  b=a%b;
		  a=tmp;
	  }
      cout<<ans+1<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值