Team Formation

本文探讨了马加尔大学校长埃德华如何通过技能水平的异或运算,筛选出能够发挥最佳合作的参赛队伍,确保团队在编程竞赛中表现出色。通过详细解释异或运算在团队组建中的应用,文章提供了具体的算法实现,帮助读者理解如何通过数学方法优化团队构成。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

给你n个数,从中选出满足两个数的异或的值大于两个数中的任意一个,问能找出多少个

首先将所有的输入的十进制数都看作32位二进制表示(假设)。bit[i]表示第位有多少个1;

然后遍历给出的数据,对于每一个数据都从左向右,只要在这个过程中出现异或为真,那么必定

满足条件

 

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const double pi = acos(-1.0);
int t,n,a[100005],bit[100];

int main()
{
    int i,j,k;
    scanf("%d",&t);
    while(t--)
    {
        memset(bit,0,sizeof bit);
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            for(j = 31;j>=0;j--)
            {
                if(a[i]&(1<<j))
                {
                    bit[j]++;///存放a[i]二进制化后在第j位为1的数目
                    break;
                }
            }
        }
        LL ans = 0;
        for(int i=0;i<n;i++)
        {
            if(a[i])
            {
                int l = 31;
                while(1)
                {
                    if(a[i]&(1<<l)) break;
                    l--;
                }
                while(l>=0)
                {
                    if(!(a[i]&(1<<l))) ans+=bit[l];
                    l--;
                }
            }
        }
        printf("%lld\n",ans);
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值