DFS——Red and Black

本文介绍了一个基于深度优先搜索(DFS)算法的迷宫寻路问题解决方案。在一个由红色和黑色方块组成的矩形房间中,从一个指定的黑色方块出发,寻找所有可达的黑色方块路径。通过递归地探索四个相邻的黑色方块,避免红色障碍,最终统计并返回可到达的所有黑色方块数量。文章提供了完整的C语言实现代码,展示了如何有效利用DFS算法解决此类问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output
45
59
6
13
与lake counting题结构相似,不过只需从一个地方开始。下面代码可以将输入与找@合并,scanf放在循环里。

#include<stdio.h>
#include<string.h>
int w,h,tx,ty,cnt=1,max=0;		//w为行数,h为列数
char a[27][27],flag[27][27];	//flag记录该位置有没被访问过
int next[4][2]={				//四个方向
 1,0,
 0,1,
-1,0,
 0,-1
};
void dfs(int x,int y){			//递归函数
	for(int v=0;v<4;v++){		//在每个地方都有四个方向可走
		int dx=x+next[v][0];
		int dy=y+next[v][1];
		if(a[dx][dy]=='.'&&dx>0&&dx<=w&&dy>0&&dy<=h&&!flag[dx][dy]){
			flag[dx][dy]=1;
			dfs(dx,dy);
		}
	}
}
int main(){
	scanf("%d %d",&h,&w);
	while(h&&w){			//都不为0
		getchar();
		for(int i=1;i<=w;i++){//输入数据
			for(int j=1;j<=h;j++){
				scanf("%c",&a[i][j]);
			}
			getchar();
		}
		memset(flag,0,sizeof(flag));
		for(int i=1;i<=w;i++){
			for(int j=1;j<=h;j++){
				if(a[i][j]=='@'){	//从@开始
					tx=i;
					ty=j;
				}
			}
		}
		dfs(tx,ty);
		for(int i=1;i<=w;i++){		//数flag表里有几个1
			for(int j=1;j<=h;j++){
				if(flag[i][j]==1){
					cnt++;
				}
			}
		}
/*		for(int i=1;i<=w;i++){		//输出flag表
			for(int j=1;j<=h;j++){
				printf("%2.d",flag[i][j]);
			}
			printf("\n");
		}*/
		printf("%d\n",cnt);
		cnt=1;
		scanf("%d %d",&h,&w);
	}
	return 0;
}
"black and red problem"通常是指图论中的“黑红树”(Black-Red Tree),这是一种用于实现二叉查找树的数据结构。Python中的深度优先搜索(Depth-First Search,DFS)可以用来遍历这种特殊的树。 在处理这类问题的DFS解法中,你需要递归地访问每个节点,并维护两个颜色规则:每个节点要么是红色,要么是黑色,且根节点必须是黑色。两个额外的规则是: 1. 每个叶节点(NIL节点)都是黑色的。 2. 如果一个节点是红色的,则其子节点必须是黑色。 DFS通常会采用一种叫做预置颜色(preorder coloring)的策略,即先访问左子树,然后访问右子树。在遍历时,需要确保每次遇到红色节点时都进行了正确的调整,以保持树的平衡和黑色节点的性质。 下面是一个简单的Python DFS解法示例,假设有一个名为`Node`的类表示树节点,包含`color`(颜色)和`left`, `right`属性: ```python class Node: def __init__(self, color): self.color = color self.left = None self.right = None def is_valid_b_and_r(node): if node is None: return True # 检查当前节点是否违反规则 if node.color != 'red': return is_valid_b_and_r(node.left) and is_valid_b_and_r(node.right) # 深度检查子节点的颜色和位置 left_red = node.left and node.left.color == 'red' right_red = node.right and node.right.color == 'red' # 父亲节点为红色,子节点不能同时为红色 if left_red and right_red: return False # 深入左子树或右子树并检查它们是否有效 if left_red: return is_valid_b_and_r(node.left.left) and is_valid_b_and_r(node.left.right) elif right_red: return is_valid_b_and_r(node.right.left) and is_valid_b_and_r(node.right.right) # 如果到达这里说明所有子节点都不是红色 return True # 示例用法 root = ... # 创建一个代表树的根节点 if is_valid_b_and_r(root): print("树满足black and red规则") else: print("树不满足black and red规则") ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值