An easy problem
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 9301 Accepted Submission(s): 2293
Problem Description
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..
One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?
Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?
Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
Input
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10
10).
Output
For each case, output the number of ways in one line.
Sample Input
2 1 3
Sample Output
0 1
很简单的一个问题,化简一下就行了 n+1=(i+1)*(j+1);
#include<cstdio>
#define LL long long
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
LL n,sum=0,i;
scanf("%lld",&n);
n+=1;
for(i=2;i*i<=n;++i)
{
if(n%i==0)
++sum;
}
printf("%lld\n",sum);
}
return 0;
}