POJ 3278 Catch That Cow

本文介绍了一个有趣的算法问题:农民约翰如何通过步行与瞬移在最短时间内追上静止不动的逃逸奶牛。使用广度优先搜索算法进行解答。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意很简单,就是农民有三种操作,看最后能否到达牛的位置,直接bfs即可
代码如下:
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int N, K, dx;
int step = 0;
struct node {
	int N;
	int step;
}pre, nex;
int p[200005];
void bfs() {
	queue<node> q;
	pre.N = N;
	pre.step = 0;
	p[N] = 1;
	q.push(pre);
	while(!q.empty()) {
		nex = q.front();
		q.pop();
		if(nex.N == K) {
			step = nex.step;
			return ;
		}
		dx = nex.N-1;
		if(p[dx] == 0 && dx >= 0 && dx <= 100505) {
			pre.N = dx;
			pre.step = nex.step+1;
			q.push(pre);
			p[pre.N] = 1;
		}
		dx = nex.N+1;
		if(p[dx] == 0 && dx >= 0 && dx <= 100505) {
			pre.N = dx;
			pre.step = nex.step+1;
			q.push(pre);
			p[pre.N] = 1;
		}
		dx = nex.N*2;
		if(p[dx] == 0 && dx >= 0 && dx <= 100505) {
			pre.N = dx;
			pre.step = nex.step+1;
			q.push(pre);
			p[pre.N] = 1;
		}
	}
	return ;
}
int main() {
	
	while(~scanf("%d%d",&N,&K)) {
		memset(p, 0, sizeof(p));
		step = 0;
		bfs();
		printf("%d\n",step);		
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值