POJ - 2236 Wireless Network

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
 
 
 
 
一道并查集的裸题,也是纠结很久,因为一个小bug开始怀疑人生,题目就不翻译了,就是一道裸并查集,耗时有点长;然后就是注意字符输入,输入之前要先输入一个回车,或者使用cin,不然就要出错。具体代码如下;
#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <string>
#include <vector>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define inf 1<<30
#define eps 1e-10
#define maxn 300005
#define zero(a) fabs(a)<eps
#define Min(a,b) ((a)<(b)?(a):(b))
#define Max(a,b) ((a)>(b)?(a):(b))
#define pb(a) push_back(a)
#define mem(a,b) memset(a,b,sizeof(a))
#define LL long long
#define lson step<<1
#define rson step<<1|1
#define MOD 1000000009
#define sqr(a) ((a)*(a))
using namespace std;
struct node{
	int xi,yi;
	int i;
}s[1005];
int getf(int v) {
	if(v != s[v].i) {
		s[v].i = getf(s[v].i);
	}
	return s[v].i;
}
void merge(int v , int u , int si) {
	int t1 = getf(v);
	int t2 = getf(u);
	if(t1 != t2) {
		if(sqr(s[v].xi-s[u].xi) + sqr(s[v].yi-s[u].yi) <= sqr(si))
		s[t2].i = t1;
	}
	return ;
}
int main() {
	int N, d;
	char   c;
	int p, q;
	int com[1005];
	mem(com,0);
	scanf("%d%d",&N,&d);
	for(int i = 1; i <= N; i++) {
		s[i].i = i;
		scanf("%d%d",&s[i].xi,&s[i].yi);
	}
	int flag = 0 , t = 0;
	while(cin>>c) {
		if(c == 'O') {
			scanf("%d",&p);
			for(int i = 0; i < t; i++) {
				merge(com[i] , p , d);
			}
			com[t++] = p;
		}
		else if(c == 'S') {
			scanf("%d%d",&p,&q);
			if(getf(p) == getf(q))
			printf("SUCCESS\n");
			else printf("FAIL\n");
		}
	}
	return 0;
}4766ms


 
#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <string>
#include <vector>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define inf 1<<30
#define eps 1e-10
#define maxn 300005
#define zero(a) fabs(a)<eps
#define Min(a,b) ((a)<(b)?(a):(b))
#define Max(a,b) ((a)>(b)?(a):(b))
#define pb(a) push_back(a)
#define mem(a,b) memset(a,b,sizeof(a))
#define LL long long
#define lson step<<1
#define rson step<<1|1
#define MOD 1000000009
#define sqr(a) ((a)*(a))
using namespace std;
struct node{
	int xi,yi;
	int i;
}s[1015];

int getf(int v) {
	return v == s[v].i ? v : getf(s[v].i);
}

void merge(int v , int u , int si) {
	int t1 = getf(s[v].i);
	int t2 = getf(s[u].i);
	if(t1 != t2) {
		if((sqr(s[v].xi-s[u].xi) + sqr(s[v].yi-s[u].yi)) <= sqr(si))
		s[t2].i = t1;
	}
}

int main() {
	int N, d;
	char   c;
	int p, q;
	int com[1005];
	mem(com,0);
	scanf("%d%d",&N,&d);
	for(int i = 1; i <= N; i++) {
		s[i].i = i;
		scanf("%d%d",&s[i].xi,&s[i].yi);
	}
	while(cin>>c) {
		if(c == 'O') {
			scanf("%d",&p);
			for(int i = 0; i <= N; i++) {
				if(com[i]) {
					merge(i , p, d);		
				}
			}
			com[p] = 1;
		}
		else {
			scanf("%d%d",&p,&q);
			if(getf(p) == getf(q))
			printf("SUCCESS\n");
			else printf("FAIL\n");
		}
	}
	return 0;
}
4672ms
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值