模拟:Fraction HDU - 5912

本文介绍了一个有趣的分数加法挑战问题,通过从底部开始模拟计算连续分数的过程,最终得出简化后的分数形式。文章提供了完整的算法思路及C语言实现代码。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below: 
 

As a talent, can you figure out the answer correctly?
Input
The first line contains only one integer T, which indicates the number of test cases. 

For each test case, the first line contains only one integer n ( n8 n≤8). 

The second line contains n integers:  a1,a2,an(1ai10 a1,a2,⋯an(1≤ai≤10). 
The third line contains n integers:  b1,b2,,bn(1bi10) b1,b2,⋯,bn(1≤bi≤10).
Output
For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer. 

You should promise that p/q is irreducible.
Sample Input
1
2
1 1
2 3
Sample Output
Case #1: 1 2


        
  
Hint
Here are the details for the first sample:
2/(1+3/1) = 1/2
 
 
 
 
思路:只需要模拟这个过程,从底部开始模拟;
分子:fz; 分母:fm;
初始值:fz = b[n-1]; fm = a[n-1];
然后:
for(int i = n - 2; i >= 0; i--) {
	fz = a[i]*fm + fz;
	int t = fm;
	fm = fz;
	fz = t*b[i];
}
最后判断一个gcd(fz , fm) , 然后就A了;
 
 
 
 
#include <stdio.h>
int gcd(int m , int n) {
	if(n == 0) return m;
	else return gcd(n , m%n);
}

int main() {
	int N , sum = 0 , n;
	int a[10005];
	int b[10005];
	scanf("%d",&N);
	while(N--) {
		scanf("%d",&n);
		for(int i = 0; i < n; i++) 
		scanf("%d",&a[i]);
		for(int i = 0; i < n; i++) 
		scanf("%d",&b[i]);
		int fz = b[n - 1];
		int fm = a[n - 1];
		for(int i = n - 2; i >= 0; i--) {
			fz = a[i] * fm + fz;
			int t = fm;
			fm = fz;
			fz = t*b[i];
		}
		printf("Case #%d: %d %d\n",++sum , fz/gcd(fz , fm) , fm/gcd(fz , fm));
	}
	return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值