HDU 4738 题解

转载请注明出处,


题目:http://acm.hdu.edu.cn/showproblem.php?pid=4738

Problem Description

Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn’t give up. Caocao’s army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao’s army could easily attack Zhou Yu’s troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao’s army could be deployed very conveniently among those islands. Zhou Yu couldn’t stand with that, so he wanted to destroy some Caocao’s bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn’t be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.

Input

There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.

Output

For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn’t succeed any way, print -1 instead.

Sample Input

3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0

Sample Output

-1
4

题意:给出一个无向图(桥梁),每座桥上有一定的士兵,选择一座桥炸掉,使原图不连通,派去炸桥的士兵必须大于等于(直接等于就行)桥上的士兵,求最少排除的士兵数。

坑点:
- 如果原图本身就不连通,则答案为0
- 如果要炸的桥上没有士兵,那么还是需要派一个士兵去,即答案为1而不是0
- 筛选要炸的桥时要注意,可能存在两个结点之间的桥数不为1,此时,这两点之间的桥就一定不是轰炸对象(炸掉一座还剩一座,等于没炸)

代码:

// @Team    : nupt2017team12
// @Author  : Zst
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <vector>
#include <cmath>
#include <algorithm>
#include <map>
using namespace std;
#define LL long long
#define MOD 1000000007
#define CLR(a,x) memset(a,x,sizeof(a))
#define INF 0x3f3f3f3f
#define pb push_back
#define FOR(i,a,b) for( int i = ( a ); i <= ( b ); ++i )

const int N = 1000+7;
int bridge[N][N];
int head[N];

struct node
{
    int v, next;
    int cost;
}E[N*N];
int index;

void addEdge( int u, int v, int cost )
{
    E[index].next = head[u];
    E[index].v = v;
    E[index].cost = cost;
    head[u] = index++;
}

int n, m;

int dfn[N];
int low[N];
int times;
int ans;
void Tarjan( int u, int per )
{
    dfn[u] = low[u] = times++;
    for( int i = head[u]; i != -1; i = E[i].next ) {
        int v = E[i].v;
        if( v == per )
            continue;
        if( dfn[v] == 0 ) {
            Tarjan( v, u );
            if( dfn[u] < low[v] && bridge[u][v] == 1 ) {
                ans = min( ans, E[i].cost );
            }
            low[u] = min( low[u], low[v] );
        } else {
            low[u] = min( low[u], dfn[v] );
        }

    }
}

void solve()
{
    FOR( i, 1, n ) {
        if( dfn[i] == 0 ) {
            Tarjan( i, -1 );
        }
    }
}

bool vis[N];
void dfs( int u )
{
    vis[u] = true;
    for( int i = head[u]; i != -1; i = E[i].next ) {
        int v = E[i].v;
        if( vis[v] )
            continue;
        dfs( v );
    }
}

bool judge()
{
    CLR( vis, false );
    dfs( 1 );
    FOR( i, 1, n ) {
        if( vis[i] == false )
            return false;
    }
    return true;
}

int main()
{
    // freopen( "I.txt", "r", stdin );
    while( scanf( "%d%d", &n, &m ), n != 0 && m != 0 ) {
        CLR( head, -1 );
        index = 0;
        CLR( dfn, 0 );
        CLR( low, 0 );
        times = 1;
        ans = INF;
        CLR( bridge, 0 );

        FOR( i, 1, m ) {
            int u, v, cost;
            scanf( "%d%d%d", &u, &v, &cost );
            if( cost == 0 )
                cost = 1;
            bridge[u][v]++;
            bridge[v][u]++;
            addEdge( u, v, cost );
            addEdge( v, u, cost );
        }
        // 判断原图是否连通
        if( judge() == false ) {
            printf( "0\n");
            continue;
        }
        solve();
        printf( "%d\n", ans==INF?-1:ans );
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值