Strange fuction
Problem Description Now, here is a fuction:
F(x) = 6 * x7+8*x6+7x3+5*x2-yx (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input2
100
200
Sample Output
-74.4291
-178.8534
F(x) = 6 * x7+8*x6+7x3+5*x2-yx (0 <= x <=100)
有两种方法
第一种 二分查找 用函数的导数来写
第二种 三分查找
第一种
#include <stdio.h>
#include <math.h>
double y;
double F(double x)
{
return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double f(double x)
{
return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}
int main(int argc, char *argv[])
{
int t;
double m,l,r;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
if(f(100)<=0)
{
printf("%.4lf\n",F(100.0));
}
else
{
l=0.0;r=100.0;
while(r-l>1e-8)
{
m=(l+r)/2.0;
if(f(m)<0)
l=m;
else
r=m;
}
printf("%.4lf\n",F(m));
}
}
return 0;
}
第二种
三分查找 (数据需要是凸型的)
#include<stdio.h>
#include<math.h>
int y;
double sum;
double cal(double x)
{
sum=6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
return sum;
}
double search()
{
double left=0,right=100,mid1,mid2;
while(right-left>1e-6)
{
mid1=(left*2+right)/3;
mid2=(left+right*2)/3;
if(cal(mid1)>cal(mid2))
left=mid1;
else right=mid2;
}
return cal(right);
}
int main()
{
int num,i;
scanf("%d",&num);
for(i=0;i<num;i++)
{
scanf("%d",&y);
search();
printf("%.4lf\n",sum);
}
}